CVE-2026-88011·Traefik vulnerability
Traefik is an open source HTTP reverse proxy and load balancer. Prior to 2.11.56, and from 3.0.0 until 3.7.12, a client-supplied dot-form header such as X.Authenticated.User survives ForwardAuth replacement and underscoreHeadersStrategy because Go treats it as distinct from X-Authenticated-User while normalization-prone CGI, WSGI, PHP, and NGINX backends collapse both names. A backend can consequently consume the client value instead of the identity Traefik asserted, allowing identity spoofing for any header managed by Traefik. The aliasHeadersStrategy protection is disabled by default and must be configured as delete or reject. The mitigation is available in 2.11.56 and 3.7.12.
- Severity
- high
- Software
- Traefik
- Fixed in
- 3.7.12
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.42% — higher than 34% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-88011 scores 8.1 on CVSS, so a successful attack would be serious — but at 0.42%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.0.0
Until: 3.7.12
Fixed in: 3.7.12
How to fix this CVE
Upgrade Traefik to version 3.7.12 or later to patch the header spoofing vulnerability that allows attackers to bypass ForwardAuth identity assertions. Organizations using versions 3.0.0 through 3.7.11 should prioritize this update, as the flaw permits client-supplied headers with dot notation to override Traefik-managed authentication headers in downstream backends. Additionally, enable the aliasHeadersStrategy with delete or reject mode to add defense-in-depth protection against header manipulation attacks.
sudo dnf update traefikDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
POST|GET .* HTTP/[0-9.]+ .*(X\.[A-Za-z]+\.[A-Za-z]+|x\.[a-z]+\.[a-z]+).*(Authenticated|User|Token|Auth)WAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Implement WAF rules to reject requests containing headers with dot notation in names (e.g., X.*, x.*) that are not explicitly whitelisted, and enforce strict header validation to prevent client-supplied override of authentication headers managed by reverse proxies.How to check if you are affected
- Check installed Traefik version: traefik version or grep -i version /path/to/traefik/binary
- Verify ForwardAuth middleware is configured: grep -r 'forwardauth\|ForwardAuth' /etc/traefik/ or your configuration directory
- Search access logs for suspicious dot-notation headers: grep -E 'X\..*\.|x\..*\.' /var/log/traefik/access.log
- Confirm upgrade by re-running traefik version and validating the output shows 3.7.12 or higher
FAQ
What is CVE-2026-88011?
This vulnerability allows attackers to inject headers using dot notation (e.g., X.Authenticated.User) that bypass Traefik's header normalization and ForwardAuth identity protection, enabling identity spoofing on backends that collapse header name formats like NGINX, PHP, and WSGI environments.
Is CVE-2026-88011 being actively exploited?
No, this vulnerability is not listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are currently available, though the attack is straightforward if headers are accessible to client input.
What versions of Traefik are affected by CVE-2026-88011?
Traefik versions 3.0.0 through 3.7.11 are vulnerable; version 2.11.56 and earlier 2.x releases are also affected but the 3.x branch is the primary focus for remediation.
How do I check if my server is vulnerable to CVE-2026-88011?
Run `traefik version` and compare the output to 3.7.12; if your version is between 3.0.0 and 3.7.11, or below 2.11.56, your instance is vulnerable.
Does Defensia detect CVE-2026-88011?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-88011 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
- https://github.com/traefik/traefik/commit/0331801c72329e0eaeb850e53ccce87c57fbecf8
- https://github.com/traefik/traefik/pull/13720
- https://github.com/traefik/traefik/releases/tag/v2.11.56
- https://github.com/traefik/traefik/releases/tag/v3.7.12
- https://github.com/traefik/traefik/security/advisories/GHSA-rf44-j88r-hh8c
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-88011. Free for 1 server.
Get started free