CVE-2026-54763·Traefik vulnerability
Traefik is an HTTP reverse proxy and load balancer. Prior to v2.11.51, v3.6.22, and v3.7.6, Traefik's BasicAuth, DigestAuth, and ForwardAuth middlewares strip canonical-cased spoofed identity headers before writing Traefik's own value, but do not account for underscore-variant header names, which many backends normalize identically to dashed forms. An attacker able to reach a protected route can inject an underscore-variant header that survives Traefik's stripping and reaches the backend alongside, or on the unauthenticated ForwardAuth authResponseHeaders path instead of, the value Traefik intended to set, spoofing identity or authorization context. This issue is fixed in versions v2.11.51, v3.6.22, and v3.7.6.
- Severity
- critical
- Software
- Traefik
- Fixed in
- 3.7.6
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.24% — higher than 14% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-54763 scores 10 on CVSS, so a successful attack would be serious — but at 0.24%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.7.0
Until: 3.7.6
Fixed in: 3.7.6
How to fix this CVE
Upgrade Traefik immediately to version 3.7.6 or later to patch header injection vulnerabilities in authentication middlewares. The vulnerability allows attackers to bypass identity verification by injecting underscore-variant HTTP headers that evade Traefik's sanitization logic. Ensure all reverse proxy instances are updated and restarted to apply the security fix.
sudo dnf update traefikDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
GET|POST|PUT|DELETE .* HTTP/1\.1.*\n(.*\n)*(authorization|x_forwarded_user|remote_user|x_remote_user|cookie): .*WAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Block or normalize HTTP headers containing underscore-variant names before routing to backend services. Implement header canonicalization rules to convert underscore-prefixed headers to dashed equivalents and reject requests with both variants present simultaneously.How to check if you are affected
- Step 1: Check installed Traefik version with: traefik version or docker inspect $(docker ps -q -f 'ancestor=traefik') | grep -i version
- Step 2: Verify if BasicAuth, DigestAuth, or ForwardAuth middleware is enabled in traefik.yml or dynamic configuration by grepping for 'basicAuth\|digestAuth\|forwardAuth'
- Step 3: Search access logs for requests containing underscore-prefixed header variants (e.g., 'authorization', 'x_forwarded_user', 'remote_user') that don't match canonical dashed versions
- Step 4: After patching, confirm version shows v3.7.6 or higher and restart with: sudo systemctl restart traefik or docker-compose restart traefik
FAQ
What is CVE-2026-54763?
CVE-2026-54763 is a header injection vulnerability in Traefik's authentication middlewares where underscore-variant HTTP header names bypass security filtering, allowing attackers to spoof identity claims and bypass authorization checks on protected routes.
Is CVE-2026-54763 being actively exploited?
No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available, though the attack technique is straightforward and should be treated with urgency.
What versions of Traefik are affected by CVE-2026-54763?
Traefik versions 3.7.0 through 3.7.5 are vulnerable. The v2.11.x and v3.6.x branches have corresponding affected versions that are patched in v2.11.51 and v3.6.22 respectively.
How do I check if my server is vulnerable to CVE-2026-54763?
Run 'traefik version' and compare the version number against 3.7.6. If the version is 3.7.5 or lower and you have any auth middleware enabled, your deployment is vulnerable until patched.
Does Defensia detect CVE-2026-54763?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-54763 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-54763. Free for 1 server.
Get started free