CVE-2026-44774·Traefik vulnerability
Traefik is an HTTP reverse proxy and load balancer. Prior to 2.11.46, 3.6.17, and 3.7.1, Traefik's Kubernetes Gateway API provider allows a tenant with HTTPRoute creation permissions to expose the REST provider handler, bypassing the providers.rest.insecure=false setting. The Gateway provider accepts any TraefikService backend reference whose name ends with @internal, making it possible to route traffic to rest@internal in addition to the intended api@internal. In shared Gateway deployments where the REST provider is enabled, this allows a low-privileged actor to gain live dynamic configuration write access to Traefik, enabling unauthorized reconfiguration of routers and services. This vulnerability is fixed in 2.11.46, 3.6.17, and 3.7.1.
- Severity
- critical
- Software
- Traefik
- Fixed in
- 3.7.1
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.55% — higher than 44% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-44774 scores 9.9 on CVSS, so a successful attack would be serious — but at 0.55%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.7.0
Until: 3.7.1
Fixed in: 3.7.1
How to fix this CVE
Upgrade Traefik to version 3.7.1 or later to patch the Kubernetes Gateway API provider vulnerability. This update restricts unauthorized access to the REST provider handler and prevents low-privileged users from bypassing security settings. Verify the upgrade by checking the version output and reviewing your HTTPRoute configurations to ensure no unintended @internal service references exist.
sudo dnf update traefik-3.7.1Defensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
POST|PUT|DELETE /api/routers|/api/services matching patterns like 'rest@internal' or '@internal' in the request body or path, combined with X-Forwarded-For headers or ServiceAccount tokens from non-admin users in Kubernetes audit logsWAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Implement a WAF rule to block any HTTP requests to Traefik's REST API endpoint (/api/*) originating from non-admin source IPs or lacking valid Traefik admin credentials. Rate-limit HTTPRoute creation requests in your Kubernetes ingress controller and monitor for suspicious TraefikService backend references containing '@internal'.How to check if you are affected
- Step 1: Check installed Traefik version by running: traefik version or check your deployment with kubectl get deployment traefik -o jsonpath='{.spec.template.spec.containers[0].image}'
- Step 2: Verify REST provider is enabled in your Traefik config: grep -r 'rest:' /etc/traefik/ or check your Helm values for providers.rest settings
- Step 3: Search logs for unexpected HTTPRoute creations targeting @internal services: grep -i 'rest@internal\|api@internal' /var/log/traefik/access.log
- Step 4: Confirm the patch by running traefik version and verifying the output shows 3.7.1 or higher
Indicators of compromise
- HTTPRoute resources with spec.rules[*].backendRefs[*].name matching '.*@internal'
- Traefik API calls to /api/routers or /api/services from ServiceAccounts with only HTTPRoute creation permissions
- Requests to rest@internal or api@internal endpoints from non-localhost origins in Traefik access logs
FAQ
What is CVE-2026-44774?
This is a privilege escalation vulnerability in Traefik's Kubernetes Gateway API provider where low-privileged users who can create HTTPRoutes can exploit a logic flaw to route traffic to the REST provider endpoint, gaining unauthorized configuration write access to the entire Traefik instance.
Is CVE-2026-44774 being actively exploited?
According to CISA, this vulnerability is not currently listed in the Known Exploited Vulnerabilities (KEV) catalog, and no public exploits are available. However, the attack is straightforward and organizations should prioritize patching in multi-tenant Kubernetes environments.
What versions of Traefik are affected by CVE-2026-44774?
Traefik versions 3.7.0 through 3.7.0 are affected. Earlier branches (2.11.x and 3.6.x) also have vulnerable versions—2.11.45 and earlier, 3.6.16 and earlier.
How do I check if my server is vulnerable to CVE-2026-44774?
Run 'traefik version' to check your installed version. If it shows 3.7.0 or earlier (for the 3.7 branch), you are vulnerable. Additionally, inspect your Traefik configuration with 'grep providers.rest /etc/traefik/traefik.yaml' to confirm if the REST provider is enabled.
Does Defensia detect CVE-2026-44774?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-44774 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-44774. Free for 1 server.
Get started free