CVE-2026-48020·Traefik vulnerability
Traefik is an HTTP reverse proxy and load balancer. Prior to 2.11.48, 3.6.19, and 3.7.3, there is a high severity vulnerability in Traefik's StripPrefix middleware that allows an unauthenticated attacker to bypass route-level authentication and authorization. When a public router matches on a PathPrefix rule and applies the StripPrefix middleware, a request path containing .. or its percent-encoded form %2e%2e can match the public route at routing time and then, after the prefix is stripped and the path is normalized, resolve to a path served by a separate, authenticated router. As a result, an attacker can reach protected backend paths — such as admin or internal configuration endpoints — without satisfying the authentication middleware attached to the protected router. This vulnerability is fixed in 2.11.48, 3.6.19, and 3.7.3.
- Severity
- critical
- Software
- Traefik
- Fixed in
- 3.7.3
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.78% — higher than 55% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-48020 scores 10 on CVSS, so a successful attack would be serious — but at 0.78%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.7.0
Until: 3.7.3
Fixed in: 3.7.3
How to fix this CVE
Upgrade Traefik immediately to version 3.7.3 or later to patch a critical authentication bypass vulnerability in the StripPrefix middleware. The vulnerability allows attackers to bypass route-level access controls by crafting requests with path traversal sequences. If you cannot upgrade immediately, disable or reconfigure StripPrefix middleware rules that protect sensitive endpoints until the patch is applied.
sudo dnf update traefik-3.7.3 || sudo dnf install traefik-3.7.3Defensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
POST|GET|PUT|DELETE .*(\.\.|"%2e%2e")[/\w]* — Log lines showing requests with path traversal sequences matching public PathPrefix routes but resolving to authenticated endpoints after stripping.WAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Configure WAF rules to block HTTP requests containing unencoded '..' and percent-encoded '%2e%2e' sequences in the URL path. Implement strict path validation before Traefik's routing engine processes the request, or temporarily block access to admin/protected endpoints at the WAF level until Traefik is patched.How to check if you are affected
- Run 'traefik version' or check the version in your Traefik configuration dashboard to identify the currently deployed version.
- Audit your Traefik configuration file (usually traefik.yml or dynamic config) for StripPrefix middleware attached to public routes with PathPrefix rules.
- Search Traefik access logs for requests containing '..' or '%2e%2e' in the path that match public route patterns but resolve to protected endpoints after normalization.
- After upgrading to 3.7.3, re-run 'traefik version' and restart the service to confirm the fix is active: 'sudo systemctl restart traefik'.
FAQ
What is CVE-2026-48020?
CVE-2026-48020 is a critical authentication bypass vulnerability in Traefik's StripPrefix middleware that enables unauthenticated attackers to access protected backend services. The flaw allows path traversal sequences like '..' to circumvent authentication checks when combined with prefix stripping and path normalization.
Is CVE-2026-48020 being actively exploited?
No, CVE-2026-48020 is not currently listed on the CISA Known Exploited Vulnerabilities catalog and no public exploits are available, though the critical CVSS 10 score warrants immediate patching.
What versions of Traefik are affected by CVE-2026-48020?
Traefik versions 3.7.0 through 3.7.2 are affected. Version 3.7.3 and later contain the fix, as do patched versions 2.11.48 and 3.6.19.
How do I check if my server is vulnerable to CVE-2026-48020?
Run 'traefik version' and compare the output to 3.7.3; if your version is 3.7.0-3.7.2, you are vulnerable. Also check 'grep -r StripPrefix /etc/traefik/' to confirm the middleware is in use.
Does Defensia detect CVE-2026-48020?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-48020 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-48020. Free for 1 server.
Get started free