CVE-2026-48491·Traefik vulnerability
Traefik is an HTTP reverse proxy and load balancer. From 3.7.0 until 3.7.3, there is a high severity vulnerability in Traefik's domain-fronting protection (SNICheck) that allows an unauthenticated client to bypass mutual TLS enforced through wildcard router TLSOptions. When a router uses a wildcard host rule such as Host(*.example.com) with stricter TLS options (for example RequireAndVerifyClientCert), SNICheck resolves the TLS options for the HTTP Host header using exact map lookups only and never applies wildcard matching. If another permissive SNI is served on the same entrypoint, an attacker can complete the TLS handshake under the permissive options and then send an HTTP Host header targeting the wildcard-protected backend, reaching it without presenting a client certificate. This affects the regular HTTPS / HTTP-2 path and does not require HTTP/3. This vulnerability is fixed in 3.7.3.
- Severity
- critical
- Software
- Traefik
- Fixed in
- 3.7.3
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.36% — higher than 27% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-48491 scores 10 on CVSS, so a successful attack would be serious — but at 0.36%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.7.0
Until: 3.7.3
Fixed in: 3.7.3
How to fix this CVE
Upgrade Traefik to version 3.7.3 or later immediately to patch the SNICheck bypass vulnerability that allows attackers to circumvent mutual TLS authentication on wildcard-protected routes. This vulnerability permits unauthenticated clients to reach backend services requiring client certificates by exploiting inconsistent TLS option resolution between exact and wildcard domain matches. Restart Traefik after the upgrade to apply the security fix.
sudo dnf update traefikDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
POST|GET.*Host:.*\.example\.com.*\s+ followed by TLS handshake completion without client certificate verification errors; look for access logs showing successful requests to wildcard-protected backends that should have been rejected due to missing mandatory client certificatesHow to check if you are affected
- Run 'traefik version' or check the binary version with 'traefik --version' to confirm the installed version is below 3.7.3
- Review your Traefik configuration (traefik.yml or dynamic configs) to identify any wildcard router rules (Host(*.domain.com)) combined with TLSOptions requiring client certificates
- Examine Traefik access logs for requests to wildcard-protected backends that lack expected client certificate validation errors or TLS handshake failures
- After upgrading to 3.7.3, verify the fix with 'traefik version' and restart Traefik with 'sudo systemctl restart traefik' to confirm the patched version is running
FAQ
What is CVE-2026-48491?
This vulnerability affects Traefik's SNICheck mechanism, which fails to apply wildcard domain matching when resolving strict TLS requirements. An attacker can bypass mutual TLS authentication by completing a TLS handshake under permissive options and then sending an HTTP Host header targeting a wildcard-protected backend that requires client certificates.
Is CVE-2026-48491 being actively exploited?
No, CVE-2026-48491 is not listed in the CISA KEV (Known Exploited Vulnerabilities) catalog and no public exploits are currently available, but the critical CVSS 10.0 score indicates organizations should prioritize patching immediately.
What versions of Traefik are affected by CVE-2026-48491?
Traefik versions 3.7.0 through 3.7.2 are vulnerable; version 3.7.3 and later contain the fix.
How do I check if my server is vulnerable to CVE-2026-48491?
Run 'traefik version' and check if the output shows a version between 3.7.0 and 3.7.2. If you're running one of these versions with wildcard Host rules and TLSOptions requiring client certificates (RequireAndVerifyClientCert), your server is vulnerable.
Does Defensia detect CVE-2026-48491?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-48491 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-48491. Free for 1 server.
Get started free