CVE-2026-88009·Traefik vulnerability
Traefik is an open source HTTP reverse proxy and load balancer. Prior to 2.11.57, and 3.7.13, Traefik accepts a rootless HTTP/1 request target that Go stores in URL.Opaque while leaving URL.Path empty. The rewriteRequestBuilder path evaluates routing, path sanitization, forwardAuth, encodedCharacters, and access logging against a path normalized to / but forwards URL.Opaque verbatim to the backend, allowing cross-vhost routing bypass, path-scoped authorization bypass, and access-log evasion when the backend interprets the opaque target as a path. This issue is fixed in 2.11.57 and 3.7.13.
- Severity
- high
- Software
- Traefik
- Fixed in
- 3.7.13
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.44% — higher than 37% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-88009 scores 8.2 on CVSS, so a successful attack would be serious — but at 0.44%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.0.0
Until: 3.7.13
Fixed in: 3.7.13
How to fix this CVE
Upgrade Traefik to version 3.7.13 or later to resolve a critical HTTP request handling flaw that allows attackers to bypass routing policies and authorization controls. Organizations running versions 3.0.0 through 3.7.12 should prioritize this update immediately, as the vulnerability permits malicious actors to route requests to unintended backends and evade security logging.
sudo dnf install -y traefik-3.7.13 (via EPEL or Traefik official repository)Defensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
GET / HTTP/1.1\r\nHost: backend.example.com\r\n|POST .*?HTTP/1\.1 with encoded or opaque request targets (e.g., requests missing standard path formatting but targeting backend services)WAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Implement WAF rules to reject HTTP/1.1 requests with malformed or opaque request targets (e.g., targets that do not begin with '/' or contain unexpected percent-encoding patterns). Monitor for requests where the Host header and request target path are mismatched relative to expected routing rules.How to check if you are affected
- Step 1: Verify installed Traefik version by running: traefik version or checking docker ps for the image tag if containerized
- Step 2: Confirm if Traefik is exposed to untrusted HTTP/1.1 traffic by reviewing your ingress configuration and network policies
- Step 3: Search Traefik access logs for HTTP requests with malformed request targets (Check for requests with unusual URL encoding or missing path segments while targeting different backends than expected)
- Step 4: After upgrading, validate the fix by restarting Traefik (systemctl restart traefik or container redeploy) and confirm version output shows 3.7.13 or higher
FAQ
What is CVE-2026-88009?
A vulnerability in Traefik's HTTP/1 request handling where rootless request targets are processed inconsistently—the reverse proxy evaluates routing rules and authorization against a normalized path, but forwards the original unmodified request target to backend servers, allowing security controls to be bypassed.
Is CVE-2026-88009 being actively exploited?
No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits have been disclosed. However, the flaw is easily discoverable and should be patched promptly.
What versions of Traefik are affected by CVE-2026-88009?
Traefik versions 3.0.0 through 3.7.12 are affected. Version 2.x users on versions prior to 2.11.57 should also upgrade.
How do I check if my server is vulnerable to CVE-2026-88009?
Run 'traefik version' or check your container image tag to determine the installed version. If it is between 3.0.0 and 3.7.12 (or 2.0.0 and 2.11.56 for v2), your instance is vulnerable.
Does Defensia detect CVE-2026-88009?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-88009 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
- https://github.com/traefik/traefik/commit/58d1e9ca204526823211e30fd4634101c59d58e9
- https://github.com/traefik/traefik/pull/13796
- https://github.com/traefik/traefik/releases/tag/v2.11.57
- https://github.com/traefik/traefik/releases/tag/v3.7.13
- https://github.com/traefik/traefik/security/advisories/GHSA-f52w-8j3h-j724
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-88009. Free for 1 server.
Get started free