CVE-2026-88004·Traefik vulnerability
Traefik is an open source HTTP reverse proxy and load balancer. From 3.2.0 until 3.7.13, Traefik entrypoint defenses aliasHeadersStrategy, underscoreHeadersStrategy, and forwardedHeaders inspect req.Header but not req.Trailer, allowing an unauthenticated client to submit an aliasing or trusted header name in an HTTP/1.1 chunked trailer or an HTTP/2 trailer. When the retry or buffering middleware reads the body before the reverse proxy clones the request, the attacker-controlled trailer value reaches a backend that merges trailers into the header namespace, bypassing the documented delete or reject behavior and potentially spoofing identity or forwarded routing data. This issue is fixed in 3.7.13.
- Severity
- high
- Software
- Traefik
- Fixed in
- 3.7.13
- Published
Affected versions
From: 3.2.0
Until: 3.7.13
Fixed in: 3.7.13
How to fix this CVE
Update Traefik to version 3.7.13 or later to patch the HTTP trailer header spoofing vulnerability. This fix ensures that entrypoint defenses properly validate all header sources, including HTTP/1.1 chunked trailers and HTTP/2 trailers, preventing attackers from bypassing authentication or routing controls through trailer injection.
sudo dnf update traefikDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
POST|GET /.*HTTP/1\.1.*\r\nTransfer-Encoding: chunked.*Trailer:.*Authorization|X-Forwarded-For|X-Real-IPWAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Block or strictly validate HTTP/1.1 requests with chunked Transfer-Encoding that include Trailer headers containing sensitive header names (Authorization, X-Forwarded-For, X-Real-IP, X-Forwarded-Proto). Additionally, enforce HTTP/2 trailer header validation at ingress to reject trailers with header field names that duplicate or override critical security headers.How to check if you are affected
- Step 1: Check installed Traefik version with `traefik version` or inspect the binary at `/usr/bin/traefik --version`
- Step 2: Verify if aliasHeadersStrategy, underscoreHeadersStrategy, or forwardedHeaders are enabled in your traefik.yaml or static config by searching for these keys: `grep -E '(aliasHeadersStrategy|underscoreHeadersStrategy|forwardedHeaders)' /etc/traefik/traefik.yaml`
- Step 3: Check Traefik logs for suspicious trailer headers or chunked encoding requests with header-like values: `grep -i 'trailer\|chunked' /var/log/traefik/traefik.log | head -20`
- Step 4: Confirm the patch by running `traefik version` and verifying the version is 3.7.13 or higher, or check the commit hash in the binary metadata
FAQ
What is CVE-2026-88004?
A header validation bypass in Traefik that allows attackers to inject malicious headers through HTTP trailers, circumventing entrypoint security policies designed to block or delete sensitive headers. This can lead to authentication bypass or request routing manipulation.
Is CVE-2026-88004 being actively exploited?
No, there are no reports of active exploitation or publicly available exploits as of the current advisory date. However, the vulnerability requires only network access and no authentication, making it a high-priority target for opportunistic attacks.
What versions of Traefik are affected by CVE-2026-88004?
Traefik versions 3.2.0 through 3.7.12 are vulnerable. Version 3.7.13 and later contain the security fix.
How do I check if my server is vulnerable to CVE-2026-88004?
Run `traefik version` or inspect `/usr/bin/traefik --version` and compare against 3.7.13. If your version is between 3.2.0 and 3.7.12, you are vulnerable.
Does Defensia detect CVE-2026-88004?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-88004 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-88004. Free for 1 server.
Get started free