CVE-2026-71327·Traefik vulnerability
Traefik is an open source HTTP reverse proxy and load balancer. From 3.0.0 until 3.6.25 and 3.7.10, Traefik's Kubernetes Gateway API provider in pkg/provider/kubernetes/gateway/httproute.go, grpcroute.go, tcproute.go, and tlsroute.go builds HTTPRoute, GRPCRoute, TCPRoute, and TLSRoute router and service identities by hyphen-concatenating namespace, route name, Gateway identity, entry point, and rule index, allowing colliding Routes to overwrite another namespace's backend. This issue is fixed in 3.6.25 and 3.7.10.
- Severity
- high
- Software
- Traefik
- Fixed in
- 3.7.10
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.48% — higher than 40% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-71327 scores 8.1 on CVSS, so a successful attack would be serious — but at 0.48%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.7.0
Until: 3.7.10
Fixed in: 3.7.10
How to fix this CVE
Update Traefik immediately to version 3.7.10 or later to patch the route identity collision vulnerability in the Kubernetes Gateway API provider. This vulnerability allows attackers with access to create routes in one namespace to overwrite backend configurations belonging to other namespaces, potentially redirecting traffic or exposing sensitive services. Apply the patch during your next maintenance window to prevent cross-namespace route hijacking.
sudo dnf update traefik --refreshDefensia detects this vulnerability
How to check if you are affected
- Run `traefik --version` or check `/usr/bin/traefik --version` to identify the installed Traefik version on the system.
- Execute `kubectl get gatewayclass,gateway,httproute,grpcroute,tcproute,tlsroute --all-namespaces` to confirm if the Kubernetes Gateway API provider is actively configured.
- Search container logs with: `docker logs <container_id> 2>&1 | grep -iE '(gateway|route|collision|identity)' | tail -20` to detect any anomalies related to route processing.
- Verify the fix by running `traefik --version` post-update and confirming the version is 3.7.10 or later, then validate Gateway API routes are functioning correctly with `kubectl describe httproute -A`.
FAQ
What is CVE-2026-71327?
This vulnerability in Traefik's Kubernetes Gateway API provider allows route identity collisions where malicious routes in one namespace can overwrite backend service identities of routes in other namespaces. Attackers with namespace-level route creation permissions can exploit this to redirect traffic or expose backend services they should not access.
Is CVE-2026-71327 being actively exploited?
No, CVE-2026-71327 is not currently listed on the CISA Known Exploited Vulnerabilities catalog and no public exploits are available, but the vulnerability remains critical for multi-tenant Kubernetes deployments.
What versions of Traefik are affected by CVE-2026-71327?
Traefik versions 3.7.0 through 3.7.9 are vulnerable. Additionally, versions 3.0.0 through 3.6.24 are affected. The vulnerability is fixed in Traefik 3.7.10 and 3.6.25.
How do I check if my server is vulnerable to CVE-2026-71327?
Run `traefik --version` and check if the version falls between 3.7.0-3.7.9 or 3.0.0-3.6.24. If Kubernetes Gateway API provider is enabled (check Traefik configuration or logs for 'gateway' provider mentions), your deployment is vulnerable until patched.
Does Defensia detect CVE-2026-71327?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-71327 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
- https://github.com/traefik/traefik/commit/a764166656f0cd337f917ac76315c381cca844f9
- https://github.com/traefik/traefik/pull/13580
- https://github.com/traefik/traefik/releases/tag/v3.6.25
- https://github.com/traefik/traefik/releases/tag/v3.7.10
- https://github.com/traefik/traefik/security/advisories/GHSA-fgjj-px3w-67xx
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-71327. Free for 1 server.
Get started free