CVE-2026-71324·Traefik vulnerability
Traefik is an open source HTTP reverse proxy and load balancer. Prior to 2.11.53, 3.6.24, and 3.7.9, Traefik's default HTTP reverse proxy forwards a plain HTTP/2 or HTTP/3 CONNECT request and its body to an HTTP/1.1 upstream through a shared net/http.Transport. When the upstream answers the CONNECT with a keep-alive non-2xx response and does not drain the body, Traefik returns the desynchronized backend socket to its shared pool and reuses it for other clients. An unauthenticated attacker can use this behavior to make a different client read the attacker's smuggled response, which can include authenticated or private content from another request. The ForwardAuth middleware with forwardBody true and preserveRequestMethod true can re-issue a CONNECT with the buffered body attached, exposing the auth-client pool to the same desynchronization. This issue is fixed in 2.11.53, 3.6.24, and 3.7.9.
- Severity
- critical
- Software
- Traefik
- Fixed in
- 3.7.9
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.1% — higher than 64% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 3.7.0
Until: 3.7.9
Fixed in: 3.7.9
How to fix this CVE
Upgrade Traefik to version 3.7.9 or later to patch a critical HTTP/2 and HTTP/3 CONNECT request handling vulnerability that can lead to response smuggling and unauthorized data disclosure. Organizations running versions 3.7.0 through 3.7.8 should prioritize this update immediately. The fix prevents socket desynchronization in the reverse proxy's connection pool, which could otherwise allow attackers to intercept responses intended for other clients.
sudo dnf update traefik --assumeyesDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
POST|GET.*HTTP/(2|3).*CONNECT.*\r\n.*Connection: keep-alive|HTTP/1\.1\s+(3\d{2}|4\d{2}|5\d{2}).*(?=(?:.*\r\n){0,5}\r\n[A-Za-z0-9])WAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Block or rate-limit CONNECT tunnel requests from untrusted sources. Implement strict validation of upstream server responses to CONNECT requests, ensuring the response body is properly consumed before connection reuse. Consider enforcing HTTP/1.1 connections to upstream servers if HTTP/2 tunneling is not required.How to check if you are affected
- Step 1: Check installed Traefik version with: traefik version or grep -i version /etc/traefik/traefik.yml
- Step 2: Verify if HTTP/2 or HTTP/3 CONNECT tunneling is enabled in your Traefik configuration by checking for 'http2' or 'http3' protocol settings in backends
- Step 3: Search Traefik access and error logs for patterns like 'CONNECT.*200' or '502 Bad Gateway' followed by mismatched response bodies using: grep -E 'CONNECT|502' /var/log/traefik/access.log
- Step 4: After patching, confirm the updated version is running with: traefik version && systemctl status traefik
FAQ
What is CVE-2026-71324?
This vulnerability allows connection pool poisoning in Traefik's reverse proxy when handling HTTP/2 or HTTP/3 CONNECT requests. If an upstream server responds with a non-2xx status while leaving the connection desynchronized, Traefik may reuse that corrupted connection for subsequent client requests, causing one client to receive another client's response data.
Is CVE-2026-71324 being actively exploited?
No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog, and no public exploits are available. However, the critical CVSS score of 9.1 warrants immediate patching.
What versions of Traefik are affected by CVE-2026-71324?
Traefik versions 3.7.0 through 3.7.8 are vulnerable. Additionally, versions 2.x prior to 2.11.53 and 3.6.x prior to 3.6.24 are also affected. Upgrade to 3.7.9, 3.6.24, or 2.11.53 respectively.
How do I check if my server is vulnerable to CVE-2026-71324?
Run 'traefik version' to retrieve your installed version. If it falls within 3.7.0–3.7.8, 2.x before 2.11.53, or 3.6.x before 3.6.24, your server is vulnerable.
Does Defensia detect CVE-2026-71324?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-71324 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
- https://github.com/traefik/traefik/commit/04d36f28e4eae7535e96a6351dd9f7bfb48a30e7
- https://github.com/traefik/traefik/commit/0807b6d5dd1da8b2f7f4076ea2392b5437bf2ab0
- https://github.com/traefik/traefik/commit/94a7508817d180f0ab2f1eae93df48d4ab19ecce
- https://github.com/traefik/traefik/pull/13542
- https://github.com/traefik/traefik/pull/13543
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-71324. Free for 1 server.
Get started free