CVE-2026-67309·Traefik vulnerability
Traefik versions >= v3.7.0 and <= v3.7.7 contain a path traversal vulnerability in the Kubernetes Ingress NGINX provider's RewriteTarget middleware (generated from the nginx.ingress.kubernetes.io/rewrite-target annotation). When an Ingress path uses a regex that captures attacker-controlled text without requiring a path separator (e.g., path /api(.*) with rewrite target /$1), a crafted request such as /api../admin matches the public router, is rewritten to a dot-segment traversal path (/../admin), and is forwarded without post-replacement normalization validation. A backend that normalizes dot segments resolves the path to a protected endpoint (e.g., /admin) reachable only through a separate router secured with BasicAuth, DigestAuth, or ForwardAuth, resulting in route-level authentication bypass. The issue is fixed in v3.7.8.
- Severity
- high
- Software
- Traefik
- Fixed in
- 3.7.8
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.66% — higher than 51% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-67309 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.66%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.7.0
Until: 3.7.8
Fixed in: 3.7.8
How to fix this CVE
Upgrade Traefik to version 3.7.8 or later to patch a critical path traversal vulnerability in the Kubernetes Ingress NGINX RewriteTarget middleware. This vulnerability allows attackers to bypass authentication controls by crafting requests with dot-segment sequences that traverse to protected routes. Immediately apply this update if you are running Traefik v3.7.0 through v3.7.7 with Kubernetes Ingress annotations configured.
sudo dnf update traefik (ensure version 3.7.8 or later is available from your repository)Defensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
POST|GET /api\.\./(admin|protected|internal).*WAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Implement WAF rules to reject requests containing consecutive dot-segment sequences (/../ or ..\ patterns) in the URL path before they reach the Traefik router. Additionally, normalize and validate all rewritten paths server-side to prevent traversal attacks.How to check if you are affected
- Check installed Traefik version: traefik version | grep Version
- Review Kubernetes Ingress resources for nginx.ingress.kubernetes.io/rewrite-target annotations: kubectl get ingress -A -o json | jq '.items[] | select(.metadata.annotations["nginx.ingress.kubernetes.io/rewrite-target"] != null)'
- Examine access logs for requests containing dot-segment sequences (../) targeting paths that should be protected: grep -E '\.\./' /var/log/traefik/access.log
- Verify Traefik has been restarted with the patched version: traefik version and confirm it shows v3.7.8 or higher
FAQ
What is CVE-2026-67309?
CVE-2026-67309 is a path traversal vulnerability in Traefik's Kubernetes Ingress NGINX provider that allows attackers to bypass route-level authentication by injecting dot-segment sequences into requests that get rewritten through the RewriteTarget middleware. This results in unauthorized access to protected endpoints that should require BasicAuth, DigestAuth, or ForwardAuth credentials.
Is CVE-2026-67309 being actively exploited?
No, CVE-2026-67309 is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog, and no public exploits have been reported. However, the attack pattern is straightforward, so prompt patching is recommended.
What versions of Traefik are affected by CVE-2026-67309?
Traefik versions 3.7.0 through 3.7.7 are vulnerable. Version 3.7.8 and later contain the fix.
How do I check if my server is vulnerable to CVE-2026-67309?
Run 'traefik version' and check if the reported version is between 3.7.0 and 3.7.7. Then verify if you have any Kubernetes Ingress resources with the 'nginx.ingress.kubernetes.io/rewrite-target' annotation by running 'kubectl get ingress -A -o json | jq '.items[] | select(.metadata.annotations["nginx.ingress.kubernetes.io/rewrite-target"] != null)''.
Does Defensia detect CVE-2026-67309?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-67309 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
- https://github.com/traefik/traefik/commit/69259c3acc9d4bdc065cb2e3b83336f7de3e7038
- https://github.com/traefik/traefik/commit/b93f02cd07b79490fb8c8f02e301a7a1ec553195
- https://github.com/traefik/traefik/security/advisories/GHSA-8rxv-jg7p-wvg3
- https://www.vulncheck.com/advisories/traefik-path-traversal-via-rewritetarget-authentication-bypass
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-67309. Free for 1 server.
Get started free