CVE-2026-65602·Traefik vulnerability
Traefik 3.6.0 through 3.6.22 and 3.7.0 through 3.7.6 fail to enforce the crossProviderNamespaces allowlist for IngressRouteTCP service serversTransport references (the allowlist was only enforced for HTTP serversTransport references). A low-privileged Kubernetes user in a namespace not listed in crossProviderNamespaces can set serversTransport: foo@file on an IngressRouteTCP service, causing Traefik to accept the forbidden cross-provider reference and use a file-provider TCPServersTransport — including privileged backend mTLS client certificates, SPIFFE identity, or PROXY-protocol settings. This is fixed in 3.6.23 and 3.7.7.
- Severity
- high
- Software
- Traefik
- Fixed in
- 3.7.7
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.33% — higher than 25% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-65602 scores 8.8 on CVSS, so a successful attack would be serious — but at 0.33%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.7.0
Until: 3.7.7
Fixed in: 3.7.7
How to fix this CVE
Upgrade Traefik to version 3.7.7 or later to resolve this namespace bypass vulnerability in IngressRouteTCP configurations. The fix ensures that the crossProviderNamespaces allowlist is properly enforced for all serversTransport references, preventing unprivileged users from accessing restricted backend certificates and SPIFFE identities. Restart Traefik after upgrading to activate the security patch.
sudo dnf upgrade traefikDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed Traefik version by running: traefik version or docker exec <container> traefik version
- Step 2: Review IngressRouteTCP definitions in your Kubernetes cluster using: kubectl get ingressroutetcp -A -o yaml | grep -A5 'serversTransport'
- Step 3: Search Traefik logs for unauthorized serversTransport references: grep -i 'serverstransport.*@file' /var/log/traefik/traefik.log or kubectl logs <traefik-pod> | grep 'serversTransport'
- Step 4: Verify the patch by confirming the version is 3.7.7 or higher: traefik version | grep -E '(3\.7\.[7-9]|3\.8|3\.[9-9]|[4-9]\.)'
FAQ
What is CVE-2026-65602?
This vulnerability allows low-privileged Kubernetes users to bypass namespace isolation in Traefik by directly referencing serversTransport configurations from restricted namespaces via IngressRouteTCP, potentially exposing sensitive mTLS certificates and backend configuration.
Is CVE-2026-65602 being actively exploited?
No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available, but it should still be patched promptly due to its high severity rating.
What versions of Traefik are affected by CVE-2026-65602?
Traefik versions 3.6.0–3.6.22 and 3.7.0–3.7.6 are vulnerable. The fix is available in 3.6.23 and 3.7.7 or later.
How do I check if my server is vulnerable to CVE-2026-65602?
Run 'traefik version' and compare the output against the affected range (3.7.0–3.7.6). If your version falls within this range, you are vulnerable. Additionally, check for any IngressRouteTCP resources with cross-namespace serversTransport references using 'kubectl get ingressroutetcp -A -o yaml'.
Does Defensia detect CVE-2026-65602?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-65602 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-65602. Free for 1 server.
Get started free