CVE-2026-65601·Traefik vulnerability
Traefik versions 3.7.0 through 3.7.6 contain a namespace confusion vulnerability in the Kubernetes Gateway API provider. When resolving HTTPRoute.spec.rules[].backendRefs[].filters[].extensionRef, Traefik used the backend Service namespace instead of the HTTPRoute namespace. A low-privileged route author holding a ReferenceGrant for a cross-namespace Service could therefore bind a Traefik Middleware from the backend namespace without a separate grant for that middleware, potentially injecting trusted reverse-proxy identity headers into downstream requests. The issue is fixed in version 3.7.7.
- Severity
- high
- Software
- Traefik
- Fixed in
- 3.7.7
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.51% — higher than 42% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-65601 scores 8.8 on CVSS, so a successful attack would be serious — but at 0.51%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.7.0
Until: 3.7.7
Fixed in: 3.7.7
How to fix this CVE
Upgrade Traefik to version 3.7.7 or later to resolve a namespace confusion vulnerability in the Kubernetes Gateway API provider. This vulnerability allows low-privileged route authors to bypass access controls and inject middleware from ungranted namespaces. Prioritize this update if you are running Traefik with Kubernetes Gateway API integration and use cross-namespace service references.
sudo dnf update traefikDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed Traefik version with: traefik version or docker inspect <container_id> | grep -i version for containerized deployments
- Step 2: Verify if Kubernetes Gateway API provider is enabled by checking your Traefik static configuration (traefik.yml) for 'kubernetesgateway:' provider block
- Step 3: Search Traefik logs for suspicious HTTPRoute filter operations or unexpected middleware bindings: grep -i 'extensionref\|filter\|middleware' /var/log/traefik/traefik.log or container logs with docker logs <container_id> | grep -i extensionref
- Step 4: Confirm the fix by running traefik version and verifying the output shows version 3.7.7 or higher
FAQ
What is CVE-2026-65601?
This vulnerability is a namespace confusion flaw in Traefik's Kubernetes Gateway API provider that incorrectly resolves HTTPRoute filter extensionRef using the backend Service namespace instead of the HTTPRoute namespace, allowing unauthorized middleware injection across namespace boundaries.
Is CVE-2026-65601 being actively exploited?
No, this vulnerability is not currently listed on the CISA KEV catalog and no public exploits are available, though it should still be remediated promptly as it impacts authorization controls in Kubernetes environments.
What versions of Traefik are affected by CVE-2026-65601?
Traefik versions 3.7.0 through 3.7.6 are vulnerable; version 3.7.7 and later include the fix.
How do I check if my server is vulnerable to CVE-2026-65601?
Run 'traefik version' and check if the version is between 3.7.0 and 3.7.6; if so, and you have Kubernetes Gateway API provider enabled, your deployment is vulnerable.
Does Defensia detect CVE-2026-65601?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-65601 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-65601. Free for 1 server.
Get started free