CVE-2026-65600·Traefik vulnerability
Traefik versions <= v2.11.51, >= v3.6.0 <= v3.6.22, and >= v3.7.0 <= v3.7.6 contain an authentication bypass via path traversal in the ReplacePathRegex middleware. When ReplacePathRegex is configured with a regex that captures user-controlled path segments without a mandatory path separator (e.g. regex "^/api(.*)", replacement "/$1"), the middleware forwards the replaced path to the backend without validating that it matches its normalized form. An unauthenticated remote attacker can send a crafted request (e.g. GET /api../admin) that produces an un-normalized path such as /../admin, which a backend that normalizes paths resolves to a protected route, bypassing authentication middleware. Fixed in v2.11.52, v3.6.23, and v3.7.7.
- Severity
- medium
- Software
- Traefik
- Fixed in
- 3.7.7
- Published
Affected versions
From: 3.7.0
Until: 3.7.7
Fixed in: 3.7.7
How to fix this CVE
Upgrade Traefik to version 3.7.7 or later to address a path traversal vulnerability in the ReplacePathRegex middleware that allows unauthenticated attackers to bypass authentication controls. Organizations using versions 3.7.0 through 3.7.6 should prioritize this update, as the flaw enables crafted requests to reach protected backend routes without proper authorization.
sudo dnf update traefikDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
GET /api\.\./ OR GET /api%2e%2e/ OR POST /api/../admin OR GET /service/../../../admin followed by HTTP 200 or 3xx response when authentication should have been requiredWAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Block HTTP requests containing unencoded path traversal sequences (../, ..\ ) or encoded variants (%2e%2e%2f, %252e%252e%252f) in the request path before they reach Traefik. Implement strict path normalization rules that reject requests with mixed segments that resolve to parent directories.How to check if you are affected
- Check installed Traefik version: traefik version or docker inspect $(docker ps -q -f ancestor=traefik) | grep -i version
- Verify ReplacePathRegex middleware configuration: grep -r "ReplacePathRegex" /etc/traefik/ or check dynamic configuration files for regex patterns without mandatory separators
- Search logs for suspicious path traversal patterns: grep -E '\.\./' /var/log/traefik/access.log or check access logs for requests containing encoded traversal sequences like %2e%2e%2f
- After upgrading, confirm the new version: traefik version should report 3.7.7 or later
FAQ
What is CVE-2026-65600?
This vulnerability affects Traefik's ReplacePathRegex middleware, which fails to normalize paths after applying regex-based replacements. An attacker can craft requests with path traversal sequences that bypass authentication middleware and reach protected backend resources.
Is CVE-2026-65600 being actively exploited?
No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog, and no public exploits are available, though organizations should still prioritize patching due to the authentication bypass risk.
What versions of Traefik are affected by CVE-2026-65600?
Versions 3.7.0 through 3.7.6 are affected. Additionally, versions 2.x up to 2.11.51 and 3.6.0 through 3.6.22 are vulnerable. Traefik 3.7.7, 3.6.23, and 2.11.52 contain the fix.
How do I check if my server is vulnerable to CVE-2026-65600?
Run 'traefik version' and compare against the affected ranges. If you're running 3.7.0–3.7.6, check your dynamic configuration files for ReplacePathRegex rules with regex patterns lacking mandatory path separators (e.g., '^/api(.*)' replacement '/$1').
Does Defensia detect CVE-2026-65600?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-65600 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-65600. Free for 1 server.
Get started free