CVE-2026-54764·Traefik vulnerability
Traefik is an HTTP reverse proxy and load balancer. Prior to v2.11.51, v3.6.22, and v3.7.6, Traefik's ForwardAuth middleware, even when configured with trustForwardHeader: false, derives the X-Forwarded-Port header sent to the authentication service from the original incoming request instead of the sanitized forwarded request. As a result, an unauthenticated remote attacker can inject an X-Forwarded-Proto: https header over a plain HTTP connection and cause Traefik to forward X-Forwarded-Port: 443 to the authentication service, bypassing port-based authorization checks. This issue is fixed in versions v2.11.51, v3.6.22, and v3.7.6.
- Severity
- medium
- Software
- Traefik
- Fixed in
- 3.7.6
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.28% — higher than 20% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 3.7.0
Until: 3.7.6
Fixed in: 3.7.6
How to fix this CVE
Update Traefik to version 3.7.6 or later to resolve the header injection vulnerability affecting the ForwardAuth middleware. Organizations using Traefik 3.7.0-3.7.5 should prioritize this update as it addresses a flaw where malicious X-Forwarded-Proto headers can bypass port-based authorization controls in authentication services.
sudo dnf update traefikDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
X-Forwarded-Proto: https\s+.*X-Forwarded-Port: 443|POST|GET.*HTTP/1\.[01]\s+.*X-Forwarded-Proto:\s*httpsWAF mitigation (if patching is not yet possible)
Add this rule to your WAF to block exploitation attempts while you schedule the patch.
Implement WAF rules to block or flag HTTP requests containing X-Forwarded-Proto: https or X-Forwarded-Port: 443 headers unless originating from trusted internal proxy IP addresses. Enforce strict header validation to reject mismatched protocol-port combinations (e.g., https on port 80).How to check if you are affected
- Check installed Traefik version: traefik version | grep Version
- Verify ForwardAuth middleware is configured: grep -r "forwardAuth" /etc/traefik/ or grep -r "ForwardAuth" /path/to/traefik/config
- Search logs for suspicious X-Forwarded-Proto headers over HTTP connections: grep -i "x-forwarded-proto.*https" /var/log/traefik/access.log | grep -v 'https://'
- Confirm upgrade success by running: traefik version and verifying output shows 3.7.6 or higher
FAQ
What is CVE-2026-54764?
CVE-2026-54764 is a header injection vulnerability in Traefik's ForwardAuth middleware that allows unauthenticated attackers to inject X-Forwarded-Proto headers over plain HTTP, causing the middleware to forward spoofed port information to backend authentication services and bypass port-based authorization policies.
Is CVE-2026-54764 being actively exploited?
No, this vulnerability is not currently listed on CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available, though the attack method is straightforward and requires only HTTP header manipulation.
What versions of Traefik are affected by CVE-2026-54764?
Traefik versions 3.7.0 through 3.7.5 are affected; versions 2.11.51, 3.6.22, and 3.7.6 or later contain the fix.
How do I check if my server is vulnerable to CVE-2026-54764?
Run `traefik version` and confirm your version is at or above 3.7.6. If you see 3.7.0-3.7.5, check your Traefik configuration with `grep -r 'forwardAuth' /etc/traefik/` to determine if the middleware is active.
Does Defensia detect CVE-2026-54764?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-54764 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-54764. Free for 1 server.
Get started free