CVE-2026-54762·Traefik vulnerability
Traefik is an HTTP reverse proxy and load balancer. From 3.7.0-ea.1 until 3.7.5, there is a medium severity vulnerability in Traefik's Kubernetes Ingress NGINX provider that causes affected routes to fail open. When an Ingress explicitly enables BasicAuth or DigestAuth through the supported nginx.ingress.kubernetes.io/auth-type and auth-secret annotations, but the referenced auth Secret cannot be resolved or parsed, Traefik logs the resolution error, skips installing the authentication middleware, and still emits a router to the backend service. A route that operators intended to protect is therefore published to the data plane without its authentication control, allowing unauthenticated access to the backend. The trigger is an invalid or unresolved auth dependency — a missing, malformed, unreadable, or policy-denied Secret — rather than an intentionally unprotected route. This vulnerability is fixed in 3.7.5.
- Severity
- high
- Software
- Traefik
- Fixed in
- 3.7.5
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.43% — higher than 36% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-54762 scores 8.6 on CVSS, so a successful attack would be serious — but at 0.43%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.7.0
Until: 3.7.5
Fixed in: 3.7.5
How to fix this CVE
Upgrade Traefik to version 3.7.5 or later to resolve an authentication bypass vulnerability in the Kubernetes Ingress NGINX provider. When authentication secrets fail to load or parse, the vulnerable versions incorrectly publish routes without their intended authentication controls, exposing backend services to unauthenticated access. Immediately audit your Kubernetes Ingress configurations for BasicAuth and DigestAuth annotations to identify potentially exposed routes.
sudo dnf update traefik --refresh || sudo dnf install traefik-3.7.5Defensia detects this vulnerability
How to check if you are affected
- Check installed Traefik version: traefik version or kubectl exec -it <traefik-pod> -n kube-system -- traefik version
- List all Ingress resources with nginx.ingress.kubernetes.io/auth-type annotation: kubectl get ingress -A -o jsonpath='{range .items[*]}{.metadata.namespace}{" "}{.metadata.name}{" "}{.metadata.annotations.nginx\.ingress\.kubernetes\.io/auth-type}{"\n"}{end}'
- Review Traefik logs for unresolved auth secret errors: kubectl logs -n kube-system <traefik-pod> | grep -i 'auth.*secret' | grep -i 'error\|failed\|unresolved'
- Verify fix by checking Traefik version is >= 3.7.5: traefik version | grep Version
FAQ
What is CVE-2026-54762?
CVE-2026-54762 is an authentication bypass vulnerability in Traefik's Kubernetes NGINX Ingress provider where routes configured with BasicAuth or DigestAuth are published without authentication controls when the referenced auth secrets cannot be resolved or parsed, exposing backend services to unauthorized access.
Is CVE-2026-54762 being actively exploited?
No, this vulnerability is not currently tracked in the CISA Known Exploited Vulnerabilities (KEV) catalog, and no public exploits are known to be available at this time.
What versions of Traefik are affected by CVE-2026-54762?
Traefik versions 3.7.0 through 3.7.4 (specifically 3.7.0-ea.1 to 3.7.4) are affected. Version 3.7.5 and later contain the fix.
How do I check if my server is vulnerable to CVE-2026-54762?
Run 'traefik version' and confirm the version is below 3.7.5, then inspect your Kubernetes Ingress objects for nginx.ingress.kubernetes.io/auth-type annotations with missing or malformed auth-secret references.
Does Defensia detect CVE-2026-54762?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-54762 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-54762. Free for 1 server.
Get started free