CVE-2026-54761·Traefik vulnerability
Traefik is an HTTP reverse proxy and load balancer. Prior to 3.6.21 and 3.7.5, there is a high severity vulnerability in Traefik's Kubernetes Gateway provider affecting the crossProviderNamespaces allowlist. For HTTPRoute rules that declare multiple (WRR) backendRefs, Traefik evaluates the allowlist against the target backendRef.namespace instead of the route's own namespace. As a result, an HTTPRoute created in a namespace that is not allow-listed can reference a cross-provider TraefikService such as api@internal, dashboard@internal or rest@internal by pointing backendRef.namespace at an allow-listed namespace covered by a Gateway API ReferenceGrant, exposing internal Traefik services on the data plane. Exploitation requires the ability to create an accepted HTTPRoute and a matching ReferenceGrant from an allow-listed namespace; it does not require any change to Traefik static configuration, RBAC, or the deployment itself. This vulnerability is fixed in 3.6.21 and 3.7.5.
- Severity
- high
- Software
- Traefik
- Fixed in
- 3.7.5
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.37% — higher than 28% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-54761 scores 7.1 on CVSS, so a successful attack would be serious — but at 0.37%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.7.0
Until: 3.7.5
Fixed in: 3.7.5
How to fix this CVE
Upgrade Traefik to version 3.7.5 or later to patch a namespace validation bypass in the Kubernetes Gateway provider. This vulnerability allows attackers with HTTPRoute creation permissions to expose internal Traefik services by exploiting improper allowlist validation when using multiple backend references. Update immediately if you use Kubernetes Gateway API with cross-provider namespace restrictions.
sudo dnf update traefikDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
POST|GET requests to /_internal/, /api/dashboard, or /rest endpoints originating from HTTPRoutes in non-allowlisted namespaces; access logs showing 'api@internal', 'dashboard@internal', or 'rest@internal' in backendRef fields within HTTPRoute objectsHow to check if you are affected
- Check installed Traefik version: traefik version or grep -i version /path/to/traefik/config.yaml
- Verify if Kubernetes Gateway API provider is enabled: grep -i 'kubernetesgateway\|providers.kubernetesgateway' /path/to/traefik/static-config.yaml
- Check for HTTPRoutes with multiple backendRefs: kubectl get httproutes -A -o yaml | grep -A 5 'backendRefs'
- Review audit logs for access to internal services (api@internal, dashboard@internal, rest@internal): kubectl logs -n traefik deployment/traefik | grep -i 'api@internal\|dashboard@internal\|rest@internal'
FAQ
What is CVE-2026-54761?
This vulnerability allows authenticated users to bypass Kubernetes namespace restrictions in Traefik's Gateway API implementation by crafting HTTPRoutes with multiple backend references, potentially exposing internal management services like the dashboard and REST API.
Is CVE-2026-54761 being actively exploited?
No, this vulnerability is not listed as actively exploited in CISA's Known Exploited Vulnerabilities (KEV) catalog, and no public exploits are currently available.
What versions of Traefik are affected by CVE-2026-54761?
Traefik versions 3.7.0 through 3.7.4 are affected. Version 3.6.x before 3.6.21 is also vulnerable. The issue is resolved in 3.7.5 and 3.6.21.
How do I check if my server is vulnerable to CVE-2026-54761?
Run 'traefik version' and confirm the version is 3.7.0–3.7.4 or 3.6.0–3.6.20. Then verify Kubernetes Gateway API is enabled with 'grep -i kubernetesgateway /etc/traefik/traefik.yml' or check your Helm/deployment configuration.
Does Defensia detect CVE-2026-54761?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-54761 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-54761. Free for 1 server.
Get started free