CVE-2026-41181·Traefik vulnerability
Traefik is an HTTP reverse proxy and load balancer. Prior to 2.11.44, 3.6.15, and 3.7.0-rc.3, there is an information disclosure vulnerability in Traefik's errors (custom error pages) middleware. When the backend returns a response matching the configured status range, the middleware forwards the original request's complete header set, including Authorization, Cookie, and other authentication material, to the separate error page service rather than only the minimal context needed to render the error page. This behavior is undocumented: the documentation states only that Host is forwarded by default, so operators are not warned that sensitive credentials are shared across service boundaries. Deployments using the errors middleware with a distinct error page service may inadvertently expose end-user credentials to infrastructure that was not intended to receive them. This vulnerability is fixed in 2.11.44, 3.6.15, and 3.7.0-rc.3.
- Severity
- medium
- Software
- Traefik
- Fixed in
- 3.6.15
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.50% — higher than 41% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 3.0.0
Until: 3.6.15
Fixed in: 3.6.15
How to fix this CVE
Update Traefik to version 3.6.15 or later to patch the information disclosure vulnerability in the errors middleware. The vulnerability allows sensitive HTTP headers (Authorization, Cookie, credentials) to be forwarded to custom error page services, potentially exposing authentication material to unintended infrastructure. Audit your error middleware configuration to ensure error page handlers are on trusted internal services only.
sudo dnf update traefikDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed Traefik version with `traefik version` or `docker exec <container> traefik version` for containerized deployments
- Step 2: List active middleware rules using `grep -r 'errors' /etc/traefik/` or inspect the Traefik configuration file for any error middleware definitions
- Step 3: Search access logs for error page service requests containing sensitive headers: `grep -i 'authorization\|cookie\|x-api-key' /var/log/traefik/access.log`
- Step 4: Verify the fix by confirming Traefik version is ≥3.6.15 and review the errors middleware configuration to confirm no sensitive headers are being forwarded unnecessarily
FAQ
What is CVE-2026-41181?
This is an information disclosure vulnerability in Traefik's errors middleware that unintentionally forwards sensitive HTTP headers (Authorization, Cookie, credentials) to external error page rendering services, exposing authentication material beyond the intended service boundary.
Is CVE-2026-41181 being actively exploited?
No, this vulnerability is not listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available. However, the vulnerability can be exploited if an attacker controls or monitors the error page service endpoint.
What versions of Traefik are affected by CVE-2026-41181?
Traefik versions 3.0.0 through 3.6.14 are vulnerable. Version 3.6.15 and later patch this issue. Earlier major versions (2.x) received fixes in version 2.11.44.
How do I check if my server is vulnerable to CVE-2026-41181?
Run `traefik version` and confirm your version is older than 3.6.15. Then inspect your Traefik configuration for error middleware definitions: `grep -A5 'middlewares:.*errors' /etc/traefik/traefik.yml`
Does Defensia detect CVE-2026-41181?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-41181 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-41181. Free for 1 server.
Get started free