CVE-2026-114638·Traefik vulnerability
Traefik v3.7.0 before v3.7.14 contains an improper authentication vulnerability in the Kubernetes Ingress NGINX provider that merges client CAs when auth-tls-secret names collide after dot-to-dash normalization. Attackers holding certificates from another host's CA can access a host requiring its own client CA, while that host's legitimate clients are refused.
- Severity
- high
- Software
- Traefik
- Fixed in
- 3.7.14
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.22% — higher than 12% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-114638 scores 8.7 on CVSS, so a successful attack would be serious — but at 0.22%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 3.7.0
Until: 3.7.14
Fixed in: 3.7.14
How to fix this CVE
Upgrade Traefik to version 3.7.14 or later to resolve the client certificate authority (CA) collision vulnerability affecting the Kubernetes Ingress NGINX provider. This update prevents attackers from bypassing client authentication by exploiting name normalization collisions in CA certificate handling. Immediately apply this patch in environments using Traefik with Kubernetes ingress and client TLS authentication enabled.
sudo dnf check-update && sudo dnf install traefik-3.7.14-1.el8 -yDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check Traefik version with: traefik version | grep Version (compare against 3.7.0-3.7.13)
- Step 2: Inspect Kubernetes IngressClass configuration: kubectl get ingressclass -o yaml | grep -i traefik
- Step 3: Review Traefik logs for auth-tls-secret entries: journalctl -u traefik | grep -i 'auth-tls\|certificate'
- Step 4: Verify the patch by confirming version 3.7.14+: traefik version | grep -E '3.7.(14|[1-9][0-9])|3.[8-9]'
- Step 5: Audit Kubernetes secrets for naming collisions: kubectl get secrets -o json | jq '.items[].metadata.name' | grep -E 'auth-tls' | sort
FAQ
What is CVE-2026-114638?
This vulnerability affects Traefik's Kubernetes Ingress NGINX provider, where improperly merged client certificate authorities occur when secret names are normalized (dots converted to dashes). An attacker with a valid certificate from one CA can authenticate as a different host that requires its own distinct CA, while legitimate clients get denied access.
Is CVE-2026-114638 being actively exploited?
No, CVE-2026-114638 is not currently listed in CISA's Known Exploited Vulnerabilities catalog and no public exploits are available. However, the attack requires only valid certificates from a compromised CA, making it a realistic post-compromise attack vector.
What versions of Traefik are affected by CVE-2026-114638?
Traefik versions 3.7.0 through 3.7.13 are affected. Version 3.7.14 and all later releases contain the fix.
How do I check if my server is vulnerable to CVE-2026-114638?
Run: traefik version | grep -oP 'Version v\K[0-9.]+' and compare the result against 3.7.0-3.7.13. If your version falls in this range and you use Kubernetes Ingress with auth-tls-secret configuration, your deployment is vulnerable.
Does Defensia detect CVE-2026-114638?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-114638 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-114638. Free for 1 server.
Get started free