CVE-2026-114637·Traefik vulnerability
Traefik from v3.2.0 before v3.7.14 contains an authentication bypass vulnerability in the experimental FastProxy connection pool, which fails to pin NTLM/Negotiate-authenticated backend connections to their frontend connection. Unauthenticated clients can be handed a pooled keep-alive backend connection where a victim completed an NTLM or Negotiate handshake, letting them read victim data and act as that victim.
- Severity
- high
- Software
- Traefik
- Fixed in
- 3.7.14
- Published
Affected versions
From: 3.2.0
Until: 3.7.14
Fixed in: 3.7.14
How to fix this CVE
Upgrade Traefik to version 3.7.14 or later to patch the FastProxy connection pool authentication bypass. This vulnerability allows unauthenticated clients to hijack authenticated backend connections, potentially exposing sensitive data or enabling privilege escalation. Organizations running Traefik v3.2.0 through v3.7.13 should prioritize this update, particularly if FastProxy is enabled in their configuration.
sudo dnf update traefikDefensia detects this vulnerability
How to check if you are affected
- Check installed Traefik version: traefik version | grep 'Version'
- Verify FastProxy is enabled in your static configuration: grep -r 'experimental.fastproxy' /etc/traefik/ or check your config file for experimental.fastProxy settings
- Search access logs for repeated connection reuse patterns from different source IPs to the same backend within seconds: grep -E '(Connection: keep-alive|keep-alive.*user-agent)' /var/log/traefik/access.log | sort | uniq -c | sort -rn
- Confirm the patch by running: traefik version and verifying the version is 3.7.14 or higher
FAQ
What is CVE-2026-114637?
This vulnerability in Traefik's experimental FastProxy module allows unauthenticated users to reuse keep-alive backend connections that were previously authenticated via NTLM or Negotiate protocols, bypassing authentication and exposing data from authenticated sessions.
Is CVE-2026-114637 being actively exploited?
No, this vulnerability is not listed in the CISA Known Exploited Vulnerabilities catalog and no public exploits are currently available. However, the high CVSS score (8.7) warrants prompt patching.
What versions of Traefik are affected by CVE-2026-114637?
Traefik versions 3.2.0 through 3.7.13 are vulnerable. Version 3.7.14 and all later releases contain the fix.
How do I check if my server is vulnerable to CVE-2026-114637?
Run 'traefik version' and check if the version number is between 3.2.0 and 3.7.13. Additionally, verify that experimental.fastProxy is enabled in your static configuration file.
Does Defensia detect CVE-2026-114637?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Traefik is installed on a monitored server, CVE-2026-114637 will appear in your dashboard with remediation steps.
Related Traefik CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-114637. Free for 1 server.
Get started free