CVE-2026-61109·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: JSON). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 6.5 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.41% — higher than 33% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server to version 8.0.46 or later to resolve a denial-of-service vulnerability in the JSON component. Low-privileged authenticated users can trigger server hangs or crashes by exploiting improper JSON processing logic. Apply the security patch immediately to restore availability and prevent service interruptions.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed MySQL version: mysql --version or mysql -u root -p -e 'SELECT VERSION();'
- Step 2: Verify vulnerable range: If version is between 8.4.0 and 8.4.10, or 9.7.0-9.7.1, the server is affected
- Step 3: Review MySQL error logs for repeated 'abnormal termination' or 'hang' messages: sudo tail -f /var/log/mysql/error.log
- Step 4: Confirm patch applied: After update, re-run mysql --version and verify output shows 8.0.46 or higher
FAQ
What is CVE-2026-61109?
CVE-2026-61109 is a denial-of-service vulnerability in MySQL's JSON processing component that allows authenticated attackers with low privileges to cause server crashes or hangs via malformed JSON operations.
Is CVE-2026-61109 being actively exploited?
No, this vulnerability is not listed in CISA's Known Exploited Vulnerabilities catalog and no public exploits are currently available.
What versions of MySQL are affected by CVE-2026-61109?
MySQL Server versions 8.4.0 through 8.4.10 and 9.7.0 through 9.7.1 are affected. MySQL Cluster versions 8.0.0-8.0.47, 8.4.0-8.4.10, and 9.7.0-9.7.1 are also vulnerable.
How do I check if my server is vulnerable to CVE-2026-61109?
Run 'mysql -u root -p -e "SELECT VERSION();"' and confirm the version falls within 8.4.0-8.4.10. If it does, your server requires patching to version 8.0.46 or later.
Does Defensia detect CVE-2026-61109?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-61109 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-61109. Free for 1 server.
Get started free