CVE-2026-60163·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Group Replication Plugin). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Easily exploitable vulnerability allows unauthenticated attacker with logon to the infrastructure where MySQL Server, MySQL Cluster executes to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in takeover of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 8.4 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H).
- Severity
- high
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.16% — higher than 6% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-60163 scores 8.4 on CVSS, so a successful attack would be serious — but at 0.16%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
This vulnerability affects the MySQL Group Replication plugin and allows local attackers with infrastructure access to achieve complete system compromise without authentication. Immediately upgrade MySQL Server to version 8.0.46 or later to patch the Group Replication component. Ensure all replicated instances in your cluster are updated in a coordinated manner to prevent replication failures.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Run `mysql --version` or connect to MySQL and execute `SELECT VERSION();` to identify the currently installed version
- Check if Group Replication is enabled by connecting to MySQL and running `SELECT PLUGIN_NAME, PLUGIN_STATUS FROM INFORMATION_SCHEMA.PLUGINS WHERE PLUGIN_NAME='group_replication';`
- Review MySQL error logs located at `/var/log/mysql/error.log` or the configured log path for any unauthorized connection attempts or Group Replication plugin initialization failures
- After patching, verify the new version with `mysql --version` and confirm Group Replication remains operational with `SHOW SLAVE STATUS\G` on replica nodes
FAQ
What is CVE-2026-60163?
CVE-2026-60163 is a local privilege escalation vulnerability in the MySQL Group Replication plugin that allows unauthenticated attackers with direct infrastructure access to compromise the entire MySQL Server and database cluster without requiring valid credentials.
Is CVE-2026-60163 being actively exploited?
No, there is currently no evidence of active exploitation in the wild according to CISA KEV data, and no public exploits are available.
What versions of MySQL are affected by CVE-2026-60163?
MySQL Server 8.4.0 through 8.4.10 and 9.7.0 through 9.7.1 are affected, as well as MySQL Cluster 8.0.0-8.0.47 and 8.4.0-8.4.10.
How do I check if my server is vulnerable to CVE-2026-60163?
Connect to your MySQL instance and run `SELECT VERSION();` to retrieve the version number, then compare it against the affected ranges (8.4.0-8.4.10, 9.7.0-9.7.1). Additionally, check if Group Replication is enabled with `SELECT PLUGIN_STATUS FROM INFORMATION_SCHEMA.PLUGINS WHERE PLUGIN_NAME='group_replication';`
Does Defensia detect CVE-2026-60163?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-60163 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60163. Free for 1 server.
Get started free