CVE-2026-46862·MySQL vulnerability
Vulnerability in the MySQL Router product of Oracle MySQL (component: Router: General). Supported versions that are affected are 8.4.0-8.4.9 and 9.0.0-9.7.0. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Router. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Router. CVSS 3.1 Base Score 7.5 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H).
- Severity
- high
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.20.04.1+esm3
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.45% — higher than 36% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-46862 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.45%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 9.0.0
Until: 9.7.0
Fixed in: 8.0.46-0ubuntu0.20.04.1+esm3
How to fix this CVE
MySQL Router versions 9.0.0 through 9.7.0 contain a denial-of-service vulnerability accessible over TLS without authentication. Upgrade to MySQL Router 9.8.0 or later, or apply the security patch from Oracle's June 2026 CPU advisory immediately. Ensure all MySQL Router instances in your environment are updated and restarted to mitigate the risk of service disruption.
sudo dnf update mysql-serverDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
TLS handshake followed by abnormal connection close or protocol violation; watch for patterns like: 'Connection reset by peer', 'TLS alert', or 'unexpected EOF' in MySQL Router logs immediately preceding a service crash or hang eventHow to check if you are affected
- Step 1: Check MySQL Router version with: mysql-router --version or /usr/bin/mysql-router --version
- Step 2: Verify if MySQL Router is exposed to the network by running: netstat -tlnp | grep mysql-router or ss -tlnp | grep mysql-router
- Step 3: Review MySQL Router logs for unexpected connection terminations or crashes: grep -i 'crash\|segfault\|hang' /var/log/mysql/router.log or /var/log/mysqlrouter/*.log
- Step 4: After patching, restart MySQL Router with: sudo systemctl restart mysqlrouter and confirm no errors appear in logs within 5 minutes
FAQ
What is CVE-2026-46862?
CVE-2026-46862 is a high-severity denial-of-service flaw in MySQL Router that allows unauthenticated attackers to crash or hang the Router service by sending specially crafted TLS connections, disrupting all routing services.
Is CVE-2026-46862 being actively exploited?
No, there is no evidence of active exploitation in the wild according to CISA's KEV catalog, and no public exploit code is currently available.
What versions of MySQL are affected by CVE-2026-46862?
MySQL Router versions 9.0.0 through 9.7.0 are affected; earlier versions like 8.4.0–8.4.9 are also vulnerable. The fix is available in MySQL Router 9.8.0 and later.
How do I check if my server is vulnerable to CVE-2026-46862?
Run mysql-router --version and compare the output against the affected range (9.0.0–9.7.0). If your version falls within this range, your system is vulnerable.
Does Defensia detect CVE-2026-46862?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL Router is installed on a monitored server, CVE-2026-46862 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-46862. Free for 1 server.
Get started free