CVE-2026-60316·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: X Plugin). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in takeover of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 7.2 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H).
- Severity
- high
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.37% — higher than 29% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-60316 scores 7.2 on CVSS, so a successful attack would be serious — but at 0.37%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
MySQL Server 8.4.0 through 8.4.10 and 9.7.0 through 9.7.1 contain a critical privilege escalation vulnerability in the X Plugin component that allows high-privileged attackers to gain complete control over the database server. Immediately upgrade to MySQL 8.0.46 or later, or apply the latest security patch for your affected version branch. Verify the update is installed and restart the MySQL service to ensure the vulnerable code is no longer in memory.
sudo dnf update mysql-server && sudo systemctl restart mysqldDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed MySQL version with `mysql --version` or connect to the server and run `SELECT VERSION();` to confirm if you are running 8.4.0-8.4.10, 9.7.0-9.7.1, 8.0.0-8.0.47, or other affected versions.
- Step 2: Verify the X Plugin is enabled by querying `SHOW PLUGINS;` and checking for the 'mysqlx' plugin — if present and active, your server is potentially exploitable via network protocols like X Protocol (default port 33060).
- Step 3: Search MySQL error logs (`/var/log/mysql/error.log` on Ubuntu/Debian or `/var/log/mysqld.log` on RHEL/CentOS) for unusual authentication failures, connection resets, or privilege-related errors from high-privileged accounts.
- Step 4: After patching, re-run `SELECT VERSION();` to confirm the update was applied, then check `SHOW PLUGINS;` to ensure the X Plugin has been updated to the patched version.
FAQ
What is CVE-2026-60316?
CVE-2026-60316 is a high-severity privilege escalation flaw in MySQL's X Plugin that permits high-privileged attackers with network access to execute arbitrary operations and fully compromise the MySQL Server or Cluster. The vulnerability requires attacker authentication but can lead to complete data theft, corruption, or service disruption.
Is CVE-2026-60316 being actively exploited?
No, CVE-2026-60316 is not currently listed in CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploit code has been disclosed. However, given its high CVSS score and ease of exploitation by authenticated users, defensive patching should not be delayed.
What versions of MySQL are affected by CVE-2026-60316?
MySQL Server versions 8.4.0 through 8.4.10 and 9.7.0 through 9.7.1 are affected, as well as MySQL Cluster versions 8.0.0 through 8.0.47, 8.4.0 through 8.4.10, and 9.7.0 through 9.7.1. Version 8.0.46 and earlier stable releases have been patched.
How do I check if my server is vulnerable to CVE-2026-60316?
Run `mysql --version` or connect to MySQL and execute `SELECT VERSION();` to determine your installed version. If it falls within 8.4.0–8.4.10, 9.7.0–9.7.1, or 8.0.0–8.0.47, cross-reference your specific patch level to confirm vulnerability status.
Does Defensia detect CVE-2026-60316?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-60316 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60316. Free for 1 server.
Get started free