CVE-2026-60315·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: X Plugin). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server, MySQL Cluster and unauthorized read access to a subset of MySQL Server, MySQL Cluster accessible data. CVSS 3.1 Base Score 8.2 (Confidentiality and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H).
- Severity
- high
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.25% — higher than 17% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-60315 scores 8.2 on CVSS, so a successful attack would be serious — but at 0.25%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server immediately to version 8.0.46 or later to patch the X Plugin vulnerability that allows remote attackers to trigger denial-of-service conditions and read sensitive data without authentication. Apply the update through your distribution's package manager, then restart the MySQL service to ensure the patched code is loaded. Verify the updated version is running before returning the system to production.
sudo dnf update mysql-server && sudo systemctl restart mysqldDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
POST|GET requests to port 33060 (X Protocol) or 3306 (MySQL) from external IPs with malformed authentication packets; MySQL error logs showing 'X Protocol' errors followed by connection resets or crashes; patterns: 'Connection refused on X Protocol', 'Aborted connection', 'Fatal signal 11' in mysqld error log.How to check if you are affected
- Run `mysql --version` or `SELECT VERSION();` in the MySQL client to check your installed version against the vulnerable ranges (8.4.0-8.4.10, 9.7.0-9.7.1, or 8.0.0-8.0.47 for Cluster).
- Verify that the X Plugin is enabled by checking the MySQL configuration file `/etc/mysql/mysql.conf.d/mysqld.cnf` or running `SHOW PLUGINS;` to confirm `mysqlx` is listed.
- Search MySQL error logs (typically `/var/log/mysql/error.log`) for unexpected connection attempts, protocol errors, or crashes with patterns like 'X Protocol', 'mysqlx_port', or segmentation fault messages.
- After patching, confirm the update with `mysql --version` and verify the service restarted cleanly by checking `sudo systemctl status mysql` or `sudo systemctl status mysqld` for any startup errors.
FAQ
What is CVE-2026-60315?
CVE-2026-60315 is a high-severity vulnerability in MySQL's X Plugin component that allows unauthenticated remote attackers to crash the database server or leak sensitive data through network protocols without requiring valid credentials.
Is CVE-2026-60315 being actively exploited?
No, CVE-2026-60315 is not currently listed in CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available, but organizations should still prioritize patching due to the high CVSS score (8.2) and ease of exploitation.
What versions of MySQL are affected by CVE-2026-60315?
MySQL Server versions 8.4.0 through 8.4.10 and 9.7.0 through 9.7.1 are affected, along with MySQL Cluster versions 8.0.0 through 8.0.47, 8.4.0 through 8.4.10, and 9.7.0 through 9.7.1.
How do I check if my server is vulnerable to CVE-2026-60315?
Log into your MySQL instance and run `SELECT VERSION();` to retrieve the version number, then compare it against the vulnerable ranges listed above. Additionally, confirm that the X Plugin is active by running `SHOW PLUGINS;` and looking for the mysqlx entry.
Does Defensia detect CVE-2026-60315?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-60315 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60315. Free for 1 server.
Get started free