CVE-2026-61094·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Replication). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in takeover of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 7.2 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H).
- Severity
- high
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.45% — higher than 37% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-61094 scores 7.2 on CVSS, so a successful attack would be serious — but at 0.45%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server to version 8.0.46 or later to patch CVE-2026-61094, which affects replication functionality and allows high-privileged attackers with network access to compromise the database server. This vulnerability impacts confidentiality, integrity, and availability of your MySQL instances. Apply the update immediately to prevent potential database takeover and unauthorized access to sensitive data.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed MySQL version with: mysql --version or mysqld --version
- Step 2: Connect to MySQL and query: SELECT VERSION(); to confirm the running version matches installed binaries
- Step 3: Review MySQL error logs for replication-related errors: grep -i 'replication\|slave\|replica' /var/log/mysql/error.log
- Step 4: After patching, verify the new version is active by restarting the service (sudo systemctl restart mysql) and re-running mysql --version
FAQ
What is CVE-2026-61094?
CVE-2026-61094 is a critical vulnerability in MySQL Server's replication component that allows high-privileged network attackers to compromise the entire database server, potentially leading to full system takeover with unauthorized access to all data.
Is CVE-2026-61094 being actively exploited?
No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available, though organizations should still prioritize patching due to the high severity score.
What versions of MySQL are affected by CVE-2026-61094?
MySQL Server versions 8.4.0 through 8.4.10 and 9.7.0 through 9.7.1 are affected, as well as MySQL Cluster versions 8.0.0-8.0.47, 8.4.0-8.4.10, and 9.7.0-9.7.1.
How do I check if my server is vulnerable to CVE-2026-61094?
Run 'mysql --version' or connect to the database and execute 'SELECT VERSION();' — if the output shows version 8.4.0-8.4.10 or 9.7.0-9.7.1, your instance is vulnerable and requires immediate updating.
Does Defensia detect CVE-2026-61094?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-61094 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-61094. Free for 1 server.
Get started free