CVE-2026-60747·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Replication). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Easily exploitable vulnerability allows unauthenticated attacker with logon to the infrastructure where MySQL Server, MySQL Cluster executes to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 6.2 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.14% — higher than 4% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
MySQL Server versions 8.4.0 through 8.4.10 contain a replication component vulnerability that allows local attackers to trigger denial-of-service conditions. Upgrade to version 8.0.46 or later, or apply the latest patch from Oracle's July 2026 security advisory. Local system access is required to exploit this flaw, making it critical to restrict server access and keep MySQL updated.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Check installed MySQL version: mysql --version or mysql -e 'SELECT VERSION();'
- Verify replication status: mysql -e 'SHOW SLAVE STATUS\G;' to confirm if replication is active and potentially exposed
- Search MySQL error logs for crash or hang patterns: grep -i 'crashed\|hang\|shutdown' /var/log/mysql/error.log
- Confirm patch application: mysql -e 'SELECT VERSION();' should show version 8.0.46 or later
FAQ
What is CVE-2026-60747?
CVE-2026-60747 is a replication vulnerability in MySQL Server that allows local attackers to cause the database server to hang or crash repeatedly, resulting in complete denial of service. The vulnerability affects the replication component and requires local system access to exploit.
Is CVE-2026-60747 being actively exploited?
No, this vulnerability is not currently listed in CISA's Known Exploited Vulnerabilities catalog, and no public exploits are available. However, organizations should prioritize patching due to the ease of local exploitation.
What versions of MySQL are affected by CVE-2026-60747?
MySQL Server versions 8.4.0 through 8.4.10, 9.7.0 through 9.7.1, and MySQL Cluster versions 8.0.0 through 8.0.47, 8.4.0 through 8.4.10, and 9.7.0 through 9.7.1 are affected.
How do I check if my server is vulnerable to CVE-2026-60747?
Run 'mysql --version' or 'mysql -e "SELECT VERSION();"' and check if your version falls within the affected ranges (8.4.0-8.4.10 or 9.7.0-9.7.1). If yes, your installation is vulnerable.
Does Defensia detect CVE-2026-60747?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-60747 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60747. Free for 1 server.
Get started free