CVE-2026-60332·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Group Replication GCS). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Difficult to exploit vulnerability allows high privileged attacker with logon to the infrastructure where MySQL Server, MySQL Cluster executes to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in takeover of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 6.4 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.14% — higher than 4% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server to version 8.0.46 or later to address this Group Replication GCS vulnerability affecting local privilege escalation. Organizations running MySQL 8.4.0-8.4.10 or 9.7.0-9.7.1 should prioritize this patch, as successful exploitation by high-privileged local users can result in complete server compromise. Apply the update during a maintenance window and verify replication cluster stability post-deployment.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Check installed MySQL version: mysql --version or mysql -V
- Query running version in MySQL console: SELECT @@VERSION; to confirm active server version matches installed package
- Verify Group Replication status: SHOW SLAVE STATUS\G or SELECT * FROM replication_group_members; to identify if GCS component is actively used
- Review MySQL error logs for GCS-related crashes or privilege escalation attempts: sudo tail -100 /var/log/mysql/error.log | grep -i 'group\|replication\|gcs'
- Confirm patch application: mysql --version should report 8.0.46 or newer after update, then restart MySQL service and verify: sudo systemctl restart mysql && mysql -V
FAQ
What is CVE-2026-60332?
CVE-2026-60332 is a local privilege escalation vulnerability in MySQL's Group Replication GCS (Group Communication System) component that allows high-privileged local users to escalate privileges and take over the server. The vulnerability requires local infrastructure access and high-level privileges, making it a threat primarily in shared hosting or compromised system environments.
Is CVE-2026-60332 being actively exploited?
No, CVE-2026-60332 is not listed in CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploits are currently available. However, the medium severity rating and complete system compromise impact warrant timely patching.
What versions of MySQL are affected by CVE-2026-60332?
MySQL Server versions 8.4.0 through 8.4.10 and 9.7.0 through 9.7.1 are vulnerable, along with MySQL Cluster versions 8.0.0-8.0.47, 8.4.0-8.4.10, and 9.7.0-9.7.1. Version 8.0.46 and above resolves the vulnerability.
How do I check if my server is vulnerable to CVE-2026-60332?
Run mysql --version to retrieve your installed version, then compare against the affected ranges (8.4.0-8.4.10 or 9.7.0-9.7.1). If your version falls within these ranges and you use Group Replication, your system is vulnerable.
Does Defensia detect CVE-2026-60332?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-60332 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60332. Free for 1 server.
Get started free