CVE-2026-60331·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Replication). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Difficult to exploit vulnerability allows high privileged attacker with logon to the infrastructure where MySQL Server, MySQL Cluster executes to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in takeover of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 6.4 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.14% — higher than 4% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
MySQL Server versions 8.4.0 through 8.4.10 contain a replication component vulnerability that allows high-privileged local attackers to achieve complete system compromise. Immediately update to MySQL 8.0.46 or later and verify your installation uses only authenticated, trusted administrative access. Restrict local system access to database infrastructure and review recent replication logs for suspicious activity.
sudo dnf upgrade mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed MySQL version with: mysql --version or SELECT @@version;
- Step 2: Verify if replication is enabled with: SHOW SLAVE STATUS\G or SHOW REPLICA STATUS\G (check if Slave_IO_Running and Slave_SQL_Running are both Yes)
- Step 3: Review MySQL error logs for unusual replication thread behavior: sudo tail -f /var/log/mysql/error.log | grep -i 'replication\|replica\|slave'
- Step 4: Confirm the fix by re-running mysql --version and verifying version is 8.0.46 or higher, and no longer in the 8.4.0-8.4.10 range
FAQ
What is CVE-2026-60331?
CVE-2026-60331 is a local privilege escalation vulnerability in MySQL's replication component that allows an authenticated high-privileged user with system access to gain complete control over the MySQL Server process. The vulnerability is difficult to exploit but has severe impact on confidentiality, integrity, and availability.
Is CVE-2026-60331 being actively exploited?
No, CVE-2026-60331 is not listed on the CISA Known Exploited Vulnerabilities catalog and no public exploits are currently available. However, the high severity impact means patching should not be delayed.
What versions of MySQL are affected by CVE-2026-60331?
MySQL Server versions 8.4.0 through 8.4.10, version 9.7.0 through 9.7.1, and MySQL Cluster versions 8.0.0 through 8.0.47, 8.4.0 through 8.4.10, and 9.7.0 through 9.7.1 are affected.
How do I check if my server is vulnerable to CVE-2026-60331?
Connect to MySQL and run: SELECT @@version; If the output shows version 8.4.0 through 8.4.10 or 9.7.0 through 9.7.1, your server is vulnerable and requires immediate patching.
Does Defensia detect CVE-2026-60331?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-60331 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60331. Free for 1 server.
Get started free