CVE-2026-60189·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Replication). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.31% — higher than 23% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
MySQL Server installations running versions 8.4.0 through 8.4.10 contain a replication component vulnerability that allows high-privileged attackers to trigger denial-of-service conditions through network-based exploitation. Upgrade to MySQL 8.0.46 or later to remediate this issue. Apply updates during a scheduled maintenance window to minimize service disruption.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed MySQL version with: mysql --version or mysql -u root -p -e 'SELECT VERSION();'
- Step 2: Verify replication status with: mysql -u root -p -e 'SHOW SLAVE STATUS\G;' or 'SHOW REPLICA STATUS\G;' to confirm if replication is active
- Step 3: Search MySQL error logs for unexpected server restarts or hang events: grep -i 'hang\|crash\|restart' /var/log/mysql/error.log
- Step 4: Confirm patch installation by comparing current version against 8.0.46 or later: mysql -u root -p -e 'SELECT VERSION();' and verify it is not in the 8.4.0-8.4.10 range
FAQ
What is CVE-2026-60189?
CVE-2026-60189 is a denial-of-service vulnerability in MySQL Server's replication component that allows privileged network attackers to crash or hang the database server under specific conditions.
Is CVE-2026-60189 being actively exploited?
No, this vulnerability is not currently listed in the CISA Known Exploited Vulnerabilities catalog and no public exploits are available.
What versions of MySQL are affected by CVE-2026-60189?
MySQL Server versions 8.4.0 through 8.4.10, 9.7.0 through 9.7.1, and MySQL Cluster 8.0.0 through 8.0.47, 8.4.0 through 8.4.10, and 9.7.0 through 9.7.1 are affected.
How do I check if my server is vulnerable to CVE-2026-60189?
Run 'mysql -u root -p -e "SELECT VERSION();"' and compare the version string. If it falls within 8.4.0-8.4.10 or 9.7.0-9.7.1, your instance is vulnerable.
Does Defensia detect CVE-2026-60189?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-60189 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60189. Free for 1 server.
Get started free