CVE-2026-60187·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Replication). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.34% — higher than 27% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server to version 8.0.46 or later to patch a replication component vulnerability that can cause denial of service. This vulnerability requires high-level database privileges and complex exploitation conditions, but administrators should prioritize patching to prevent potential service disruptions. Apply the update during a maintenance window and verify replication functionality post-deployment.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Check installed MySQL version: mysql --version or SELECT VERSION(); from the MySQL client
- Identify replication status: SHOW SLAVE STATUS\G or SHOW REPLICA STATUS\G to verify if replication is active
- Review error logs for unexplained crashes or hangs: grep -i 'crash\|hang\|fatal' /var/log/mysql/error.log
- Confirm successful patching: Verify the version matches 8.0.46 or later and test replication sync after update
FAQ
What is CVE-2026-60187?
CVE-2026-60187 is a denial-of-service vulnerability in MySQL's replication component that allows privileged attackers to trigger service crashes or hangs by exploiting a flaw in the replication protocol handling.
Is CVE-2026-60187 being actively exploited?
No, this vulnerability is not currently listed in the CISA Known Exploited Vulnerabilities catalog and no public exploits are available. However, the attack complexity is high and requires administrative credentials.
What versions of MySQL are affected by CVE-2026-60187?
MySQL Server versions 8.4.0 through 8.4.10, 9.7.0 through 9.7.1, and MySQL Cluster versions 8.0.0 through 8.0.47, 8.4.0 through 8.4.10, and 9.7.0 through 9.7.1 are affected.
How do I check if my server is vulnerable to CVE-2026-60187?
Run 'mysql --version' or execute 'SELECT VERSION();' in MySQL client. If the version falls within 8.4.0-8.4.10 or 9.7.0-9.7.1 range, your server is vulnerable and requires immediate patching.
Does Defensia detect CVE-2026-60187?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-60187 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60187. Free for 1 server.
Get started free