CVE-2026-60178·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Clone Plugin). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in takeover of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 6.6 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.35% — higher than 28% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server to version 8.0.46-0ubuntu0.22.04.4 or later to patch a privilege escalation vulnerability in the Clone Plugin. This vulnerability requires high administrative privileges to exploit but can result in complete system compromise. Apply the security update immediately to all affected MySQL instances.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check your MySQL version by running: mysql --version or mysql -u root -p -e 'SELECT VERSION();'
- Step 2: Verify if the Clone Plugin is enabled by executing: mysql -u root -p -e 'SELECT PLUGIN_NAME, PLUGIN_STATUS FROM INFORMATION_SCHEMA.PLUGINS WHERE PLUGIN_NAME="clone";'
- Step 3: Search MySQL error logs for Clone Plugin activity: grep -i 'clone' /var/log/mysql/error.log | grep -i 'error\|warning'
- Step 4: After patching, confirm the update: mysql --version and verify no errors in mysql error.log related to the Clone Plugin
FAQ
What is CVE-2026-60178?
CVE-2026-60178 is a privilege escalation vulnerability in MySQL Server's Clone Plugin that allows high-privileged attackers to bypass security controls and potentially take over the database server through network access.
Is CVE-2026-60178 being actively exploited?
No, according to CISA's Known Exploited Vulnerabilities catalog, this vulnerability is not currently being actively exploited in the wild. However, immediate patching is still recommended due to the severity of the impact.
What versions of MySQL are affected by CVE-2026-60178?
MySQL Server versions 8.4.0 through 8.4.10, 9.7.0 through 9.7.1, and MySQL Cluster versions 8.0.0 through 8.0.47, 8.4.0 through 8.4.10, and 9.7.0 through 9.7.1 are affected.
How do I check if my server is vulnerable to CVE-2026-60178?
Run: mysql --version to check your version number. If it falls within 8.4.0-8.4.10 or 9.7.0-9.7.1 ranges, your server is vulnerable. Additionally, verify Clone Plugin status with: mysql -u root -p -e 'SHOW PLUGINS;' and look for the clone plugin entry.
Does Defensia detect CVE-2026-60178?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-60178 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60178. Free for 1 server.
Get started free