CVE-2026-60177·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Clone Plugin). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.34% — higher than 27% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server to version 8.0.46 or later to patch the Clone Plugin denial-of-service vulnerability. This fix prevents high-privileged attackers from triggering server hangs or crashes through the Clone component. Apply the update during a maintenance window and verify the new version is running before resuming normal operations.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed MySQL version by running: mysql --version or SELECT VERSION(); from the MySQL client
- Step 2: Query the MySQL error log for Clone Plugin activity: grep -i 'clone' /var/log/mysql/error.log
- Step 3: Search for repeated connection failures or server restart events correlating with Clone Plugin operations in error logs
- Step 4: Verify the patch by confirming the version is 8.0.46 or higher and no Clone Plugin errors appear in recent logs after the upgrade
FAQ
What is CVE-2026-60177?
This vulnerability exists in MySQL's Clone Plugin component, allowing authenticated administrative users with network access to trigger a denial-of-service condition by causing the server to hang or crash repeatedly.
Is CVE-2026-60177 being actively exploited?
No, this vulnerability is not currently being actively exploited in the wild according to CISA data, and no public exploits are available.
What versions of MySQL are affected by CVE-2026-60177?
MySQL Server versions 8.4.0 through 8.4.10, and 9.7.0 through 9.7.1 are affected. MySQL Cluster versions 8.0.0-8.0.47, 8.4.0-8.4.10, and 9.7.0-9.7.1 are also vulnerable.
How do I check if my server is vulnerable to CVE-2026-60177?
Connect to MySQL and run SELECT VERSION(); If the version falls within the affected ranges (8.4.0-8.4.10 or 9.7.0-9.7.1), your server is vulnerable and requires patching.
Does Defensia detect CVE-2026-60177?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-60177 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60177. Free for 1 server.
Get started free