CVE-2026-60145·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Optimizer). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.40% — higher than 33% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server to version 8.0.46-0ubuntu0.22.04.4 or later to resolve this optimizer-related denial-of-service vulnerability. The fix addresses a query processing flaw that allows high-privileged users to trigger server hangs or crashes through specially crafted SQL statements. Prioritize this update if your environment allows administrative database access from untrusted network sources.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check your installed MySQL version by running: mysql --version or connect to MySQL and execute: SELECT VERSION();
- Step 2: Determine if remote administrative access is permitted by reviewing MySQL bind-address and user privileges: SELECT user, host FROM mysql.user WHERE Super_priv='Y';
- Step 3: Search MySQL error logs for repeated 'crash' or 'hang' messages within short timeframes: grep -i 'crash\|hang\|killed' /var/log/mysql/error.log | tail -100
- Step 4: After patching, verify the new version is running: systemctl restart mysql && mysql -e 'SELECT VERSION();' and confirm the version matches 8.0.46 or later
FAQ
What is CVE-2026-60145?
This is a denial-of-service vulnerability in MySQL's query optimizer that allows authenticated high-privileged users to craft specific SQL queries that cause the server to hang or crash repeatedly. The issue affects versions 8.4.0 through 8.4.10 and certain 9.7.x releases.
Is CVE-2026-60145 being actively exploited?
No, this vulnerability is not currently listed in CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploit code is available.
What versions of MySQL are affected by CVE-2026-60145?
MySQL Server versions 8.4.0 through 8.4.10, MySQL Cluster 8.0.0 through 8.0.47 and 8.4.0 through 8.4.10, and MySQL 9.7.0 through 9.7.1 are affected. Version 8.0.46 and earlier are not vulnerable.
How do I check if my server is vulnerable to CVE-2026-60145?
Connect to MySQL as root and run: SELECT VERSION(); If the version falls within 8.4.0-8.4.10 or 9.7.0-9.7.1 ranges, your server is vulnerable and requires immediate patching.
Does Defensia detect CVE-2026-60145?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-60145 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-60145. Free for 1 server.
Get started free