high CVSS 7.6 EPSS 0.20%

CVE-2026-50147·MariaDB vulnerability

Metabase is an open-source business intelligence and embedded analytics tool. From 1.57.0 until 1.57.19.1, 1.58.14.1, 1.59.10, and 1.60.4, an attacker who can configure a Metabase database connection can read arbitrary files from the Metabase server's filesystem by adding unsafe JDBC parameters to a MySQL or MariaDB connection, causing the driver to read files from the Metabase host and expose the contents through queries against the connected database or through validation error messages. This issue is fixed in versions 1.57.19.1, 1.58.14.1, 1.59.10, and 1.60.4.

Severity
high
Software
MariaDB
Fixed in
1.60.4
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.20% — higher than 10% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-50147 scores 7.6 on CVSS, so a successful attack would be serious — but at 0.20%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 1.60.0

Until: 1.60.4

Fixed in: 1.60.4

How to fix this CVE

Organizations running MariaDB versions 1.60.0 through 1.60.3 must upgrade to version 1.60.4 or later to patch a file disclosure vulnerability that allows privileged database connection configurators to extract sensitive files from the server filesystem. This vulnerability is amplified in environments where Metabase or similar tools manage database connections, as attackers can inject malicious JDBC parameters into connection strings to trigger unauthorized file reads. Immediately apply the patched version and review all database connection configurations for suspicious or unnecessary JDBC parameters.

sudo dnf update mariadb-server

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check installed MariaDB version with: mysql --version or mariadb --version
  2. Step 2: Query the active version in MariaDB: SELECT @@VERSION; — confirm if version is between 1.60.0 and 1.60.3
  3. Step 3: Inspect MariaDB error logs for file I/O patterns: grep -i 'file\|jdbc\|load_file' /var/log/mariadb/error.log
  4. Step 4: Verify patch application by confirming version is 1.60.4 or later, then review database connection configurations for unsafe parameters like allowLoadLocal, allowUrlInLocalInfile, or allowLoadLocalInfileInPath

FAQ

What is CVE-2026-50147?

This vulnerability affects MariaDB versions 1.60.0-1.60.3 and allows high-privilege database connection administrators to read arbitrary files from the server filesystem by injecting unsafe JDBC parameters into MySQL or MariaDB connection strings, potentially exposing configuration files, private keys, and other sensitive data.

Is CVE-2026-50147 being actively exploited?

No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities catalog and no public proof-of-concept exploits have been disclosed, though the attack requires only legitimate database configuration privileges.

What versions of MariaDB are affected by CVE-2026-50147?

MariaDB versions 1.60.0, 1.60.1, 1.60.2, and 1.60.3 are vulnerable. Earlier versions (1.57.0–1.57.18, 1.58.0–1.58.13, 1.59.0–1.59.9) are also affected in their respective release streams, with fixes available in 1.57.19.1, 1.58.14.1, 1.59.10, and 1.60.4.

How do I check if my server is vulnerable to CVE-2026-50147?

Run: mariadb --version and verify the version number. If it falls between 1.60.0 and 1.60.3, your installation is vulnerable and requires immediate patching. Additionally, check your database connection configurations for JDBC parameters such as allowLoadLocal or allowUrlInLocalInfile.

Does Defensia detect CVE-2026-50147?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-50147 will appear in your dashboard with remediation steps.

Related MariaDB CVEs

CVE-2026-49261CVSS 10MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.
CVE-2026-85748CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 12.3.1 until 12.3.3 and 13.0.2, SYS_REFCURSOR handling is affected because cursor-array reallocation can leave stale references in routine contexts. A low-privileged attacker can open a large number of SYS_REFCURSORs and then fetch one to trigger a use-after-free that can enable remote code execution when combined with another vulnerability. This issue is fixed in versions 12.3.3 and 13.0.2.
CVE-2026-85746CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, ST_AsText can write beyond an allocated output buffer when converting deeply nested GeometryCollections because recursive WKT serialization does not account for bytes consumed or reserve sufficient space. A low-privileged remote attacker can submit a specially crafted GIS object to corrupt memory and potentially achieve code execution when combined with another vulnerability. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-92262CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the #mysql50# bypass prefix is affected because it allows the #mysql50# prefix to bypass normal table-name filesystem encoding. An attacker can trigger the issue with a table name using the #mysql50# prefix, then use a #mysql50# table name to access files under their legacy unencoded name and cause crashes, data corruption, data exfiltration, or remote code execution. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-44170CVSS 9.8MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB on WIndows with installed CONNECT engine and enabled REST support interpolated table HTTP attribute into the curl command line without proper sanitizing. This allows the user to execute shell commands on the server. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-50147. Free for 1 server.

Get started free