high CVSS 8 EPSS 0.57%

CVE-2026-44168·MariaDB vulnerability

MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, during the SST the donor node is interpolating parameters that the joiner sent into the command line. Not all parameters were properly validated which could allow a malicious joiner to execute arbitrary shell commands on the donor side via the mariabackup SST method. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

Severity
high
Software
MariaDB
Fixed in
11.8.7
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.57% — higher than 43% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-44168 scores 8 on CVSS, so a successful attack would be serious — but at 0.57%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 11.8.1

Until: 11.8.7

Fixed in: 11.8.7

How to fix this CVE

MariaDB versions 11.8.1 through 11.8.6 contain a critical vulnerability in the SST (State Snapshot Transfer) mechanism where parameter validation is insufficient, allowing malicious cluster nodes to execute arbitrary shell commands on the donor node. Upgrade to MariaDB 11.8.7 or later immediately, particularly if your deployment uses mariabackup for cluster replication. After patching, restart the MariaDB service and verify cluster synchronization.

sudo dnf update mariadb-server

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check installed MariaDB version by running `mariadb --version` or connecting to the database and executing `SELECT VERSION();`
  2. Step 2: Verify if SST/mariabackup is configured in `/etc/mysql/conf.d/` or `/etc/my.cnf.d/` by searching for `wsrep_sst_method` configuration parameter
  3. Step 3: Review MariaDB error logs at `/var/log/mysql/error.log` or `/var/log/mariadb/mariadb.log` for suspicious SST donor/joiner communications or shell command injection attempts
  4. Step 4: After upgrading, confirm the new version is active with `mariadb --version` and restart the service with `sudo systemctl restart mariadb`, then check cluster status with `SHOW STATUS LIKE 'wsrep%';`

FAQ

What is CVE-2026-44168?

CVE-2026-44168 is a command injection vulnerability in MariaDB's SST (State Snapshot Transfer) mechanism where insufficient parameter validation in the mariabackup method allows a malicious cluster node to inject and execute arbitrary shell commands on the donor node with database privileges.

Is CVE-2026-44168 being actively exploited?

No, this vulnerability is not listed on the CISA KEV catalog and no public exploits are currently available, but the high CVSS score (8.0) warrants prompt patching due to the severity of potential impact if exploited.

What versions of MariaDB are affected by CVE-2026-44168?

Affected versions include 10.6.1 to 10.6.25, 10.11.1 to 10.11.16, 11.4.1 to 11.4.10, 11.8.1 to 11.8.6, and 12.3.1. For the 11.8 branch specifically, versions 11.8.1 through 11.8.6 are vulnerable.

How do I check if my server is vulnerable to CVE-2026-44168?

Run `mariadb --version` and cross-reference against the affected version ranges. Additionally, check if `wsrep_sst_method=mariabackup` is configured in your MariaDB configuration files, as this indicates the vulnerable SST method is in use.

Does Defensia detect CVE-2026-44168?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-44168 will appear in your dashboard with remediation steps.

Related MariaDB CVEs

CVE-2026-49261CVSS 10MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.
CVE-2026-85748CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 12.3.1 until 12.3.3 and 13.0.2, SYS_REFCURSOR handling is affected because cursor-array reallocation can leave stale references in routine contexts. A low-privileged attacker can open a large number of SYS_REFCURSORs and then fetch one to trigger a use-after-free that can enable remote code execution when combined with another vulnerability. This issue is fixed in versions 12.3.3 and 13.0.2.
CVE-2026-85746CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, ST_AsText can write beyond an allocated output buffer when converting deeply nested GeometryCollections because recursive WKT serialization does not account for bytes consumed or reserve sufficient space. A low-privileged remote attacker can submit a specially crafted GIS object to corrupt memory and potentially achieve code execution when combined with another vulnerability. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-92262CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the #mysql50# bypass prefix is affected because it allows the #mysql50# prefix to bypass normal table-name filesystem encoding. An attacker can trigger the issue with a table name using the #mysql50# prefix, then use a #mysql50# table name to access files under their legacy unencoded name and cause crashes, data corruption, data exfiltration, or remote code execution. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-44170CVSS 9.8MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB on WIndows with installed CONNECT engine and enabled REST support interpolated table HTTP attribute into the curl command line without proper sanitizing. This allows the user to execute shell commands on the server. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-44168. Free for 1 server.

Get started free