high CVSS 8 EPSS 0.70%

CVE-2026-48163·MariaDB vulnerability

MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.27, 10.11.1 to before 10.11.18, 11.4.1 to before 11.4.12, 11.8.1 to before 11.8.8, and 12.3.1, during the SST the donor node is interpolating parameters that the joiner sent into the command line. Not all parameters were properly validated which could allow a malicious joiner to execute arbitrary shell commands on the donor side via the rsync SST method. This issue has been patched in versions 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2.

Severity
high
Software
MariaDB
Fixed in
11.8.8
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.70% — higher than 48% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-48163 scores 8 on CVSS, so a successful attack would be serious — but at 0.70%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 11.8.1

Until: 11.8.8

Fixed in: 11.8.8

How to fix this CVE

MariaDB versions 11.8.1 through 11.8.7 contain a critical parameter injection flaw in the rsync-based SST (State Snapshot Transfer) mechanism that allows authenticated high-privilege attackers to execute arbitrary shell commands on donor nodes. Upgrade to MariaDB 11.8.8 or later immediately to patch the unsafe parameter interpolation in the SST joiner-to-donor communication flow. Ensure all MariaDB cluster nodes are updated to prevent lateral movement through replication infrastructure.

sudo dnf update mariadb-server

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed MariaDB version: mariadb --version or mysql --version
  2. Query the running version: SELECT VERSION(); from the MariaDB client
  3. Review /var/log/mariadb/mariadb.log for SST errors, rsync command failures, or unexpected shell command execution during replication initialization
  4. Verify the fix: Confirm the running version matches or exceeds 11.8.8 and review package metadata with dpkg -l mariadb-server (Debian/Ubuntu) or rpm -qa mariadb-server (RHEL/CentOS)

FAQ

What is CVE-2026-48163?

This vulnerability allows a malicious database node joining a MariaDB cluster to inject shell metacharacters through SST parameters, enabling remote command execution on the donor node with the privileges of the MariaDB process owner. The flaw exists in the rsync SST method's parameter handling during cluster state transfers.

Is CVE-2026-48163 being actively exploited?

No, there are currently no public reports of active exploitation or proof-of-concept exploits. However, this is a high-severity vulnerability affecting replication infrastructure that should be patched promptly.

What versions of MariaDB are affected by CVE-2026-48163?

Vulnerable versions include 10.6.1–10.6.26, 10.11.1–10.11.17, 11.4.1–11.4.11, 11.8.1–11.8.7, and 12.3.1. Version 11.8.8 and later branches contain the fix.

How do I check if my server is vulnerable to CVE-2026-48163?

Run mariadb --version or SELECT VERSION(); and compare against the patched versions. If your version falls within 11.8.1–11.8.7, you are vulnerable. For automated detection, use a vulnerability scanner that cross-references installed package versions against the NVD database.

Does Defensia detect CVE-2026-48163?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-48163 will appear in your dashboard with remediation steps.

Related MariaDB CVEs

CVE-2026-49261CVSS 10MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.
CVE-2026-85748CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 12.3.1 until 12.3.3 and 13.0.2, SYS_REFCURSOR handling is affected because cursor-array reallocation can leave stale references in routine contexts. A low-privileged attacker can open a large number of SYS_REFCURSORs and then fetch one to trigger a use-after-free that can enable remote code execution when combined with another vulnerability. This issue is fixed in versions 12.3.3 and 13.0.2.
CVE-2026-85746CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, ST_AsText can write beyond an allocated output buffer when converting deeply nested GeometryCollections because recursive WKT serialization does not account for bytes consumed or reserve sufficient space. A low-privileged remote attacker can submit a specially crafted GIS object to corrupt memory and potentially achieve code execution when combined with another vulnerability. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-92262CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the #mysql50# bypass prefix is affected because it allows the #mysql50# prefix to bypass normal table-name filesystem encoding. An attacker can trigger the issue with a table name using the #mysql50# prefix, then use a #mysql50# table name to access files under their legacy unencoded name and cause crashes, data corruption, data exfiltration, or remote code execution. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-44170CVSS 9.8MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB on WIndows with installed CONNECT engine and enabled REST support interpolated table HTTP attribute into the curl command line without proper sanitizing. This allows the user to execute shell commands on the server. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-48163. Free for 1 server.

Get started free