high CVSS 8.8 EPSS <0.1%

CVE-2026-22730·MariaDB vulnerability

A critical SQL injection vulnerability in Spring AI's MariaDBFilterExpressionConverter allows attackers to bypass metadata-based access controls and execute arbitrary SQL commands. The vulnerability exists due to missing input sanitization.

Severity
high
Software
MariaDB
Fixed in
1.1.3
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at <0.1% — higher than 6% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-22730 scores 8.8 on CVSS, so a successful attack would be serious — but at <0.1%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 1.1.0

Until: 1.1.3

Fixed in: 1.1.3

How to fix this CVE

Update MariaDB to version 1.1.3 or later to patch the SQL injection vulnerability in the Spring AI filter expression converter. This fix removes the missing input sanitization that allowed authenticated users to bypass access controls and execute arbitrary SQL commands. Apply the update immediately, especially in environments where Spring AI is integrated with MariaDB for vector search or AI-driven features.

sudo dnf update mariadb-server

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

SQL injection payloads in MariaDB query logs containing metadata filter expressions with embedded UNION SELECT, time-based delays (SLEEP/BENCHMARK), or boolean-based conditions; example pattern: `UNION.*SELECT|BENCHMARK\(.*,.*\)|AND.*=.*--` in authenticated query logs

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

If MariaDB is exposed through a web application layer, implement WAF rules to reject API requests containing SQL metacharacters (UNION, SELECT, --, /*, ;) in filter parameters; additionally, enforce strict input validation on all metadata-driven query endpoints and use parameterized queries exclusively.

How to check if you are affected

  1. Run `mariadb --version` or `SELECT VERSION();` in the MariaDB client to confirm the installed version. Vulnerable versions range from 1.1.0 to 1.1.2.
  2. Check if Spring AI is installed and configured with MariaDB by searching for Spring AI dependencies in your application's pom.xml or build.gradle: `grep -r 'spring-ai' /path/to/app`
  3. Search MariaDB query logs for suspicious SQL patterns combining filter expressions with UNION, subqueries, or comment sequences (-- or /* */) in authenticated sessions: `grep -i 'UNION\|--\|/\*' /var/log/mysql/mysql.log`
  4. After updating, verify the fix by running `mariadb --version` again and confirming the version is 1.1.3 or later, then restart the MariaDB service: `sudo systemctl restart mariadb`

FAQ

What is CVE-2026-22730?

CVE-2026-22730 is a SQL injection vulnerability in Spring AI's MariaDB filter expression converter that allows authenticated users to craft malicious metadata queries and execute arbitrary SQL commands, bypassing role-based access controls.

Is CVE-2026-22730 being actively exploited?

No, this vulnerability is not currently listed in CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available. However, the attack requires only valid database credentials, so it should be prioritized in internal threat scenarios.

What versions of MariaDB are affected by CVE-2026-22730?

Spring AI versions 1.1.0 through 1.1.2 are vulnerable when integrated with MariaDB. The vulnerability is patched in version 1.1.3 and later.

How do I check if my server is vulnerable to CVE-2026-22730?

Run `mariadb --version` to check the MariaDB version, and verify Spring AI version in your application build file. If Spring AI is between 1.1.0–1.1.2 and connected to MariaDB, your installation is vulnerable.

Does Defensia detect CVE-2026-22730?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-22730 will appear in your dashboard with remediation steps.

Related MariaDB CVEs

CVE-2026-49261CVSS 10MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.
CVE-2026-85748CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 12.3.1 until 12.3.3 and 13.0.2, SYS_REFCURSOR handling is affected because cursor-array reallocation can leave stale references in routine contexts. A low-privileged attacker can open a large number of SYS_REFCURSORs and then fetch one to trigger a use-after-free that can enable remote code execution when combined with another vulnerability. This issue is fixed in versions 12.3.3 and 13.0.2.
CVE-2026-85746CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, ST_AsText can write beyond an allocated output buffer when converting deeply nested GeometryCollections because recursive WKT serialization does not account for bytes consumed or reserve sufficient space. A low-privileged remote attacker can submit a specially crafted GIS object to corrupt memory and potentially achieve code execution when combined with another vulnerability. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-92262CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the #mysql50# bypass prefix is affected because it allows the #mysql50# prefix to bypass normal table-name filesystem encoding. An attacker can trigger the issue with a table name using the #mysql50# prefix, then use a #mysql50# table name to access files under their legacy unencoded name and cause crashes, data corruption, data exfiltration, or remote code execution. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-44170CVSS 9.8MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB on WIndows with installed CONNECT engine and enabled REST support interpolated table HTTP attribute into the curl command line without proper sanitizing. This allows the user to execute shell commands on the server. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-22730. Free for 1 server.

Get started free