high CVSS 8.5 EPSS 0.26%

CVE-2026-32710·MariaDB vulnerability

MariaDB server is a community developed fork of MySQL server. An authenticated user can crash MariaDB versions 11.4 before 11.4.10 and 11.8 before 11.8.6 via a bug in JSON_SCHEMA_VALID() function. Under certain conditions it might be possible to turn the crash into a remote code execution. These conditions require tight control over memory layout which is generally only attainable in a lab environment. This issue is fixed in MariaDB 11.4.10, MariaDB 11.8.6, and MariaDB 12.2.2.

Severity
high
Software
MariaDB
Fixed in
11.8.6
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.26% — higher than 49% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-32710 scores 8.5 on CVSS, so a successful attack would be serious — but at 0.26%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 11.8.1

Until: 11.8.6

Fixed in: 11.8.6

How to fix this CVE

Upgrade MariaDB to version 11.8.6 or later to patch a denial-of-service vulnerability in the JSON_SCHEMA_VALID() function that affects authenticated users. While remote code execution is theoretically possible under specific memory layout conditions, the primary risk is service disruption. Apply the security update immediately to eliminate crash vectors and ensure database stability.

sudo dnf update mariadb-server

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed MariaDB version: mysql --version or mariadb --version
  2. Query the database: SELECT VERSION(); to confirm the running server version matches the installed package
  3. Review MariaDB error logs for crash dumps: grep -i 'segmentation\|core dump\|signal 11' /var/log/mariadb/mariadb.log
  4. Verify patch application by checking if version is 11.8.6 or higher: mysql -e 'SELECT VERSION();' | grep -E '11\.(4\.10|8\.6|12\.2)'
  5. Check for recent JSON_SCHEMA_VALID() function calls in slow query logs: grep -i 'JSON_SCHEMA_VALID' /var/log/mariadb/slow.log

FAQ

What is CVE-2026-32710?

CVE-2026-32710 is a vulnerability in MariaDB's JSON_SCHEMA_VALID() function that allows authenticated users to trigger server crashes. While exploiting it for remote code execution is theoretically possible, it requires precise control over memory layout that is rarely achievable in production environments.

Is CVE-2026-32710 being actively exploited?

No, this CVE is not listed on the CISA KEV catalog and has no publicly available exploits. However, any authenticated database user can trigger the crash, making internal threat actors the primary risk.

What versions of MariaDB are affected by CVE-2026-32710?

MariaDB versions 11.4.0 through 11.4.9, and 11.8.1 through 11.8.5 are vulnerable. MariaDB 11.4.10, 11.8.6, and 12.2.2 contain the fix.

How do I check if my server is vulnerable to CVE-2026-32710?

Run 'SELECT VERSION();' in MariaDB. If the version is between 11.4.0-11.4.9 or 11.8.1-11.8.5, your server is vulnerable. If it shows 11.4.10, 11.8.6, or 12.2.2+, you are patched.

Does Defensia detect CVE-2026-32710?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-32710 will appear in your dashboard with remediation steps.

Related MariaDB CVEs

CVE-2026-49261CVSS 10MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.
CVE-2026-85748CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 12.3.1 until 12.3.3 and 13.0.2, SYS_REFCURSOR handling is affected because cursor-array reallocation can leave stale references in routine contexts. A low-privileged attacker can open a large number of SYS_REFCURSORs and then fetch one to trigger a use-after-free that can enable remote code execution when combined with another vulnerability. This issue is fixed in versions 12.3.3 and 13.0.2.
CVE-2026-85746CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, ST_AsText can write beyond an allocated output buffer when converting deeply nested GeometryCollections because recursive WKT serialization does not account for bytes consumed or reserve sufficient space. A low-privileged remote attacker can submit a specially crafted GIS object to corrupt memory and potentially achieve code execution when combined with another vulnerability. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-92262CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the #mysql50# bypass prefix is affected because it allows the #mysql50# prefix to bypass normal table-name filesystem encoding. An attacker can trigger the issue with a table name using the #mysql50# prefix, then use a #mysql50# table name to access files under their legacy unencoded name and cause crashes, data corruption, data exfiltration, or remote code execution. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-44170CVSS 9.8MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB on WIndows with installed CONNECT engine and enabled REST support interpolated table HTTP attribute into the curl command line without proper sanitizing. This allows the user to execute shell commands on the server. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-32710. Free for 1 server.

Get started free