critical CVSS 9.8 EPSS 0.80%

CVE-2026-44170·MariaDB vulnerability

MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB on WIndows with installed CONNECT engine and enabled REST support interpolated table HTTP attribute into the curl command line without proper sanitizing. This allows the user to execute shell commands on the server. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

Severity
critical
Software
MariaDB
Fixed in
11.8.7
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.80% — higher than 52% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-44170 scores 9.8 on CVSS, so a successful attack would be serious — but at 0.80%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 11.8.1

Until: 11.8.7

Fixed in: 11.8.7

How to fix this CVE

MariaDB servers running on Windows with the CONNECT engine and REST support enabled are vulnerable to remote code execution through improper sanitization of HTTP table attributes in curl commands. Immediately upgrade to MariaDB 11.8.7 or later, or disable the CONNECT engine and REST support if an immediate upgrade is not feasible. Ensure all Windows-based MariaDB deployments are patched to prevent unauthorized command execution.

sudo dnf update mariadb-server

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

curl command invocation with unsanitized HTTP table attribute values in MariaDB logs or process execution logs; payloads typically include shell metacharacters (|, &, ;, $()), e.g., 'http://attacker.com/table?cmd=<shell_command>'

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

If MariaDB REST APIs are exposed via a web interface, restrict HTTP requests to known CONNECT table endpoints and implement strict input validation on HTTP table attributes. Block requests containing shell metacharacters (|, &, ;, $, backticks, parentheses) in table attribute parameters.

How to check if you are affected

  1. Check installed MariaDB version: mysql --version or mariadb --version
  2. Verify CONNECT engine status: SELECT PLUGIN_NAME, PLUGIN_STATUS FROM INFORMATION_SCHEMA.PLUGINS WHERE PLUGIN_NAME='CONNECT';
  3. Check REST support configuration: SHOW VARIABLES LIKE 'connect_enable_rest'; (should be OFF if not needed)
  4. Confirm patch applied: SELECT VERSION(); should return 11.8.7 or later for the 11.8.x branch

FAQ

What is CVE-2026-44170?

A critical remote code execution vulnerability in MariaDB's CONNECT engine that allows unauthenticated attackers to execute arbitrary shell commands by injecting malicious input through HTTP table attributes when REST support is enabled on Windows systems.

Is CVE-2026-44170 being actively exploited?

No, this vulnerability is not currently listed in the CISA Known Exploited Vulnerabilities catalog, and no public exploits are available at this time. However, the critical severity and ease of exploitation warrant immediate patching.

What versions of MariaDB are affected by CVE-2026-44170?

Affected versions include 10.6.1–10.6.25, 10.11.1–10.11.16, 11.4.1–11.4.10, 11.8.1–11.8.6, and 12.3.1. The vulnerability is patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

How do I check if my server is vulnerable to CVE-2026-44170?

Run 'mariadb --version' to check your version number. If it falls within the affected ranges listed above and the CONNECT engine is loaded with REST enabled, your server is vulnerable.

Does Defensia detect CVE-2026-44170?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-44170 will appear in your dashboard with remediation steps.

Related MariaDB CVEs

CVE-2026-49261CVSS 10MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.
CVE-2026-85748CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 12.3.1 until 12.3.3 and 13.0.2, SYS_REFCURSOR handling is affected because cursor-array reallocation can leave stale references in routine contexts. A low-privileged attacker can open a large number of SYS_REFCURSORs and then fetch one to trigger a use-after-free that can enable remote code execution when combined with another vulnerability. This issue is fixed in versions 12.3.3 and 13.0.2.
CVE-2026-85746CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, ST_AsText can write beyond an allocated output buffer when converting deeply nested GeometryCollections because recursive WKT serialization does not account for bytes consumed or reserve sufficient space. A low-privileged remote attacker can submit a specially crafted GIS object to corrupt memory and potentially achieve code execution when combined with another vulnerability. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-92262CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the #mysql50# bypass prefix is affected because it allows the #mysql50# prefix to bypass normal table-name filesystem encoding. An attacker can trigger the issue with a table name using the #mysql50# prefix, then use a #mysql50# table name to access files under their legacy unencoded name and cause crashes, data corruption, data exfiltration, or remote code execution. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-44172CVSS 9.1MariaDB server is a community developed fork of MySQL server. In versions 3.3.18 and 3.4.8, an application that was taking non-validated user input, escaping it with mysql_real_escape_string() and sending it to the database using text protocol and big5 character set was vulnerable to SQL injections, even though mysql_real_escape_string() was supposed to prevent them. This issue has been patched in versions 3.3.19 and 3.4.9.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-44170. Free for 1 server.

Get started free