CVE-2026-47064·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Optimizer). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 6.5 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.27% — higher than 18% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server to version 8.0.46-0ubuntu0.22.04.4 or later to resolve a denial-of-service vulnerability in the query optimizer component. Authenticated attackers can trigger server crashes or hangs by sending specially crafted SQL queries. Apply this patch during a maintenance window to restore stability and prevent service interruptions.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed MySQL version by running `mysql --version` or connecting to the server and running `SELECT VERSION();`
- Step 2: Identify affected versions by confirming your installation is between 8.4.0 and 8.4.10, or 9.7.0 and 9.7.1
- Step 3: Search MySQL error logs (`/var/log/mysql/error.log`) for repeated crash dumps, stack traces, or 'Segmentation fault' messages occurring after authentication
- Step 4: Verify the patch by running `mysql --version` again after update and confirm the version number has incremented to 8.0.46 or higher
FAQ
What is CVE-2026-47064?
This is an optimizer-level denial-of-service vulnerability in MySQL Server that allows authenticated users to crash or hang the database server through malformed query execution, resulting in complete service unavailability.
Is CVE-2026-47064 being actively exploited?
No, there are currently no reports of active exploitation in the wild, and no public exploit code is available.
What versions of MySQL are affected by CVE-2026-47064?
MySQL Server versions 8.4.0 through 8.4.10, 9.7.0 through 9.7.1, and MySQL Cluster versions 8.0.0 through 8.0.47, 8.4.0 through 8.4.10, and 9.7.0 through 9.7.1 are vulnerable.
How do I check if my server is vulnerable to CVE-2026-47064?
Connect to MySQL and run `SELECT VERSION();` then compare the output against the affected version ranges (8.4.0-8.4.10, 9.7.0-9.7.1). If your version falls within these ranges, your server is vulnerable.
Does Defensia detect CVE-2026-47064?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-47064 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-47064. Free for 1 server.
Get started free