CVE-2026-47023·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Replication). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.32% — higher than 25% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server to version 8.0.46-0ubuntu0.22.04.4 or later to resolve a replication component vulnerability that allows high-privileged attackers to trigger denial-of-service conditions. Administrators should prioritize this patch as it affects the server's availability and can cause repeated crashes in production environments.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check your MySQL version by running: mysql --version or connect to the database and execute: SELECT VERSION();
- Step 2: Verify replication status by executing: SHOW SLAVE STATUS\G (for replicas) or SHOW MASTER STATUS\G (for primaries) to confirm replication is active
- Step 3: Review MySQL error logs for crash or hang events: sudo tail -f /var/log/mysql/error.log and search for 'InnoDB: Fatal error' or 'mysqld has shut down'
- Step 4: After patching, restart MySQL (sudo systemctl restart mysql) and verify the new version: mysql --version
FAQ
What is CVE-2026-47023?
CVE-2026-47023 is a vulnerability in MySQL Server's replication component that allows high-privileged attackers to cause denial-of-service by triggering server crashes or hangs through network protocols.
Is CVE-2026-47023 being actively exploited?
No, CVE-2026-47023 is not currently listed in the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available.
What versions of MySQL are affected by CVE-2026-47023?
MySQL Server versions 8.4.0 through 8.4.10, MySQL Server 9.7.0 through 9.7.1, MySQL Cluster 8.0.0 through 8.0.47, and MySQL Cluster 8.4.0 through 8.4.10 are vulnerable.
How do I check if my server is vulnerable to CVE-2026-47023?
Connect to MySQL and run: SELECT VERSION(); If the version falls within 8.4.0–8.4.10 or 9.7.0–9.7.1, your server is vulnerable and requires immediate patching.
Does Defensia detect CVE-2026-47023?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-47023 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-47023. Free for 1 server.
Get started free