CVE-2026-47012·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: Optimizer). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.34% — higher than 27% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server to version 8.0.46-0ubuntu0.22.04.4 or later to resolve a denial-of-service vulnerability in the query optimizer component that could allow high-privilege attackers to trigger server crashes. This vulnerability requires administrative credentials and specific complex query conditions to exploit, but patches should be applied promptly to prevent potential service disruptions.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed MySQL version with: mysql --version or mysql -u root -p -e 'SELECT VERSION();'
- Step 2: Verify if optimizer-based queries are being executed by checking slow query log: grep 'Query_time' /var/log/mysql/slow.log | head -20
- Step 3: Search MySQL error logs for crash signatures: grep -i 'segmentation fault\|signal 11\|aborted' /var/log/mysql/error.log
- Step 4: Confirm patch installation by running: mysql -u root -p -e 'SELECT VERSION();' and verify version is 8.0.46 or higher
FAQ
What is CVE-2026-47012?
CVE-2026-47012 is a denial-of-service vulnerability in MySQL's query optimizer component that allows authenticated high-privilege users to craft specific queries that cause the server to hang or crash, impacting availability.
Is CVE-2026-47012 being actively exploited?
No, CVE-2026-47012 is not currently listed in CISA's Known Exploited Vulnerabilities catalog and no public exploits are available, though the vulnerability should still be patched.
What versions of MySQL are affected by CVE-2026-47012?
MySQL Server versions 8.4.0 through 8.4.10 and 9.7.0 through 9.7.1 are affected, along with MySQL Cluster versions 8.0.0 through 8.0.47 and 8.4.0 through 8.4.10.
How do I check if my server is vulnerable to CVE-2026-47012?
Run 'mysql -u root -p -e "SELECT VERSION();"' and compare the output against the affected version ranges (8.4.0-8.4.10 or 9.7.0-9.7.1). If your version falls within these ranges, your system is vulnerable.
Does Defensia detect CVE-2026-47012?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-47012 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-47012. Free for 1 server.
Get started free