CVE-2026-46936·MySQL vulnerability
Vulnerability in the MySQL Server, MySQL Cluster product of Oracle MySQL (component: Server: DDL). Supported versions that are affected are MySQL Server: 8.4.0-8.4.10, 9.7.0-9.7.1; MySQL Cluster: 8.0.0-8.0.47, 8.4.0-8.4.10 and 9.7.0-9.7.1. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server, MySQL Cluster. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server, MySQL Cluster. CVSS 3.1 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).
- Severity
- medium
- Software
- MySQL
- Fixed in
- 8.0.46-0ubuntu0.22.04.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.25% — higher than 17% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 8.4.0
Until: 8.4.10
Fixed in: 8.0.46-0ubuntu0.22.04.4
How to fix this CVE
Update MySQL Server to version 8.0.46 or later to resolve a DDL component vulnerability that allows high-privileged attackers to trigger service denial through network protocols. This patch addresses the availability impact by fixing the underlying condition that causes unexpected server hangs or crashes. Administrators should prioritize this update for systems where administrative access is restricted to trusted networks.
sudo dnf update mysql-serverDefensia detects this vulnerability
How to check if you are affected
- Check installed MySQL version: mysql --version or SELECT VERSION(); from MySQL client
- Verify if vulnerable versions 8.4.0-8.4.10 or 9.7.0-9.7.1 are running: mysql -u root -p -e 'SELECT VERSION();'
- Review MySQL error logs for repeated crash dumps or 'InnoDB: Fatal error' messages: grep -i 'fatal\|crash\|hang' /var/log/mysql/error.log
- Confirm patch installation by checking package version: apt show mysql-server (Ubuntu/Debian) or rpm -qa mysql-server (RHEL/CentOS)
FAQ
What is CVE-2026-46936?
This is a denial-of-service vulnerability in MySQL's DDL (Data Definition Language) component that allows high-privileged network users to repeatedly crash or hang the MySQL service by exploiting a specific condition in schema operations.
Is CVE-2026-46936 being actively exploited?
No, this vulnerability is not listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and has no publicly available exploits, reducing immediate risk.
What versions of MySQL are affected by CVE-2026-46936?
MySQL Server versions 8.4.0 through 8.4.10, 9.7.0 through 9.7.1, and MySQL Cluster versions 8.0.0 through 8.0.47, 8.4.0 through 8.4.10, and 9.7.0 through 9.7.1 are affected.
How do I check if my server is vulnerable to CVE-2026-46936?
Run 'mysql -u root -p -e "SELECT VERSION();"' and verify the output is not within the vulnerable ranges (8.4.0-8.4.10 or 9.7.0-9.7.1 for Server; 8.0.0-8.0.47, 8.4.0-8.4.10, or 9.7.0-9.7.1 for Cluster).
Does Defensia detect CVE-2026-46936?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MySQL is installed on a monitored server, CVE-2026-46936 will appear in your dashboard with remediation steps.
Related MySQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-46936. Free for 1 server.
Get started free