CVE-2026-99154·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: scsi: libiscsi: Reject a negative task index from parse_pdu_itt A transport that implements parse_pdu_itt hands libiscsi an index taken from the PDU, and both lookups bound it from above only: if (i >= session->cmds_max) i and cmds_max are both int, so a negative index passes and session->cmds[i] is read from before the array. be2iscsi produces one. beiscsi_parse_pdu() assigns the raw tag, *index = (int)itt; and beiscsi_complete_pdu() forwards an unsolicited NOP-In from the hardware async ring without replacing its ITT, so the value is the target's. It also reports the session's own age rather than the one in the tag, which leaves the age comparison in iscsi_verify_itt() with nothing to reject. Bound the index from below in both lookups.
- Severity
- critical
- Software
- Kernel
- Fixed in
- 5.10.273, 5.15.224, 6.1.191, 6.6.161, 6.12.115, 6.18.59, 7.2.13, 7.3
- Published
How to fix this CVE
Update your Linux kernel to a patched version to resolve a critical memory access vulnerability in iSCSI protocol handling. Systems running kernel versions before 5.10.273, 5.15.224, 6.1.191, 6.6.161, 6.12.115, 6.18.59, or 7.2.13 must be patched immediately. Upgrade to the latest stable release within your current kernel branch rather than jumping to mainline, or install your distribution's provided kernel security update.
sudo dnf update kernel kernel-develDefensia detects this vulnerability
How to check if you are affected
- Run 'uname -r' to display your currently running kernel version and compare against fixed versions (5.10.273, 5.15.224, 6.1.191, 6.6.161, 6.12.115, 6.18.59, 7.2.13, or 7.3+)
- Check if iSCSI initiator is active with 'systemctl status iscsid' or 'ps aux | grep iscsi' to determine if the vulnerable code path is in use
- Search kernel logs for iSCSI-related errors: 'dmesg | grep -i iscsi' or 'journalctl -u iscsid' to identify any protocol parsing anomalies
- After patching, verify the new kernel is active with 'uname -r' and confirm it matches or exceeds the fixed version for your branch
FAQ
What is CVE-2026-99154?
This is a critical kernel vulnerability in libiscsi where negative array indices bypass bounds checking, allowing out-of-bounds memory access. The flaw occurs when iSCSI PDU parsing fails to validate task index values from the lower bound, potentially enabling denial of service or information disclosure.
Is CVE-2026-99154 being actively exploited?
No, this vulnerability is not listed on CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploit code is currently available.
What versions of Kernel are affected by CVE-2026-99154?
All kernel versions prior to the stable branch fixes: 5.10.273, 5.15.224, 6.1.191, 6.6.161, 6.12.115, 6.18.59, 7.2.13, and mainline 7.3 and later are vulnerable.
How do I check if my server is vulnerable to CVE-2026-99154?
Run 'uname -r' to get your kernel version, then compare the numeric components against the fixed versions. For example, kernel 6.6.160 is vulnerable but 6.6.161 is patched.
Does Defensia detect CVE-2026-99154?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Kernel is installed on a monitored server, CVE-2026-99154 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
- https://git.kernel.org/stable/c/0eb06ebbbecb122f0df9a1f7f623f5255be741ed
- https://git.kernel.org/stable/c/24bd9ba431b2daa263f3551bc2f09f6b4487f5ae
- https://git.kernel.org/stable/c/35b60549a956237488c89a2d85352e026e7d55b7
- https://git.kernel.org/stable/c/6200fb2de579f268742a77b0f3d823cb0a8b1947
- https://git.kernel.org/stable/c/6cadfa6f1f5896632d4223d3b7addb2a29fea74e
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-99154. Free for 1 server.
Get started free