CVE-2026-97380·MariaDB vulnerability
MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the GRANT PROXY statement treats an IDENTIFIED clause with an empty password as though authentication were not specified, causing it to check the wrong grantor privileges. A low-privileged attacker who can name another account can exploit this authorization error to set that account's password. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
- Severity
- high
- Software
- MariaDB
- Fixed in
- 12.3.3
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.56% — higher than 46% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-97380 scores 8.8 on CVSS, so a successful attack would be serious — but at 0.56%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 12.3.1
Until: 12.3.3
Fixed in: 12.3.3
How to fix this CVE
Update MariaDB to version 11.8.9 or later to patch a privilege escalation vulnerability in the GRANT PROXY statement. The vulnerability allows low-privileged users to modify passwords of other accounts by exploiting improper authentication validation when empty passwords are used. Immediate patching is critical for environments where multiple database users exist with varying privilege levels.
sudo dnf update mariadb-serverDefensia detects this vulnerability
How to check if you are affected
- Run 'mariadb --version' or 'mysql --version' to check the currently installed MariaDB version
- Query the MariaDB server with 'SELECT VERSION();' to confirm the running version matches the installed package
- Search MariaDB error logs (typically /var/log/mysql/error.log or /var/log/mariadb/mariadb.log) for GRANT PROXY statements executed by non-administrative users
- Verify the patch was applied by confirming the version is 11.8.9+ds-1 or higher using 'dpkg -l | grep mariadb-server' on Debian/Ubuntu or 'rpm -qa | grep mariadb-server' on RHEL/CentOS
FAQ
What is CVE-2026-97380?
CVE-2026-97380 is a privilege escalation vulnerability in MariaDB where the GRANT PROXY statement with an empty password incorrectly validates grantor privileges, allowing low-privileged attackers to reset passwords for arbitrary accounts they can name.
Is CVE-2026-97380 being actively exploited?
No, this vulnerability is not listed on the CISA KEV catalog and no public exploits are currently available, but the critical CVSS score of 9.0 warrants immediate patching.
What versions of MariaDB are affected by CVE-2026-97380?
Affected versions include 10.6.1 through 10.6.27, 10.11.0 through 10.11.18, 11.4.0 through 11.4.12, 11.8.0 through 11.8.8, 12.3.0 through 12.3.2, and 13.0.0 through 13.0.1. Fixed versions are 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
How do I check if my server is vulnerable to CVE-2026-97380?
Connect to MariaDB and run 'SELECT VERSION();' — if the version is below 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, or 13.0.2 (depending on your release series), your instance is vulnerable.
Does Defensia detect CVE-2026-97380?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-97380 will appear in your dashboard with remediation steps.
Related MariaDB CVEs
References
- https://github.com/MariaDB/server/commit/dbd60d0ad8daa2d01050346aa50b7b102490e456
- https://github.com/MariaDB/server/releases/tag/mariadb-10.11.19
- https://github.com/MariaDB/server/releases/tag/mariadb-10.6.28
- https://github.com/MariaDB/server/releases/tag/mariadb-11.4.13
- https://github.com/MariaDB/server/releases/tag/mariadb-11.8.9
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-97380. Free for 1 server.
Get started free