high CVSS 7.7 EPSS 0.32%

CVE-2026-86047·MariaDB vulnerability

MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, SHOW CREATE SERVER, SHOW CREATE USER, and mariadb-dump are affected because each does not consistently quote identifiers and values when serializing SQL. A low-privileged attacker can trigger the issue when an attacker-created object with crafted identifiers or values is included in SHOW output or a dump, then create an object with crafted identifiers or values so generated SQL contains injected statements and execute attacker-injected SQL when the poisoned output is applied. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

Severity
high
Software
MariaDB
Fixed in
12.3.3
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.32% — higher than 23% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-86047 scores 7.7 on CVSS, so a successful attack would be serious — but at 0.32%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 12.3.1

Until: 12.3.3

Fixed in: 12.3.3

How to fix this CVE

Update MariaDB to version 11.8.9 or later to patch SQL injection vulnerabilities in identifier and value serialization. The SHOW CREATE SERVER, SHOW CREATE USER, and mariadb-dump commands now properly quote identifiers and values, preventing attackers from injecting malicious SQL statements through crafted object definitions. Apply the update promptly to all MariaDB instances in your environment.

sudo dnf update mariadb-server

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed MariaDB version: mysql --version or mariadb --version
  2. Query the running MariaDB instance: SELECT VERSION(); and verify the version number matches or exceeds 11.8.9
  3. Examine mariadb-dump output logs for unquoted identifiers in CREATE statements (look for CREATE SERVER/USER without backticks around object names)
  4. After patching, re-run SELECT VERSION(); to confirm the update has been applied and the service restarted

FAQ

What is CVE-2026-86047?

This vulnerability allows low-privileged users to inject arbitrary SQL statements through maliciously crafted identifiers and values in SHOW CREATE SERVER, SHOW CREATE USER, and mariadb-dump output. When a database administrator applies the poisoned dump or executes the SHOW output, the injected SQL is executed in the context of their session.

Is CVE-2026-86047 being actively exploited?

No, this vulnerability is not currently listed in the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available. However, the attack vector requires low privileges and user interaction, making it a moderate operational risk.

What versions of MariaDB are affected by CVE-2026-86047?

Affected versions include: 10.6.1 through 10.6.27, 10.11.0 through 10.11.18, 11.4.0 through 11.4.12, 11.8.0 through 11.8.8, 12.3.0 through 12.3.2, and 13.0.0 through 13.0.1. The fix is available in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2 and later.

How do I check if my server is vulnerable to CVE-2026-86047?

Run 'mariadb --version' to see your installed version. If it falls within the affected ranges listed above, your server is vulnerable. Additionally, test by creating a server object with special characters in its name and running SHOW CREATE SERVER to see if identifiers are properly quoted.

Does Defensia detect CVE-2026-86047?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-86047 will appear in your dashboard with remediation steps.

Related MariaDB CVEs

CVE-2026-49261CVSS 10MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.
CVE-2026-85748CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 12.3.1 until 12.3.3 and 13.0.2, SYS_REFCURSOR handling is affected because cursor-array reallocation can leave stale references in routine contexts. A low-privileged attacker can open a large number of SYS_REFCURSORs and then fetch one to trigger a use-after-free that can enable remote code execution when combined with another vulnerability. This issue is fixed in versions 12.3.3 and 13.0.2.
CVE-2026-85746CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, ST_AsText can write beyond an allocated output buffer when converting deeply nested GeometryCollections because recursive WKT serialization does not account for bytes consumed or reserve sufficient space. A low-privileged remote attacker can submit a specially crafted GIS object to corrupt memory and potentially achieve code execution when combined with another vulnerability. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-92262CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the #mysql50# bypass prefix is affected because it allows the #mysql50# prefix to bypass normal table-name filesystem encoding. An attacker can trigger the issue with a table name using the #mysql50# prefix, then use a #mysql50# table name to access files under their legacy unencoded name and cause crashes, data corruption, data exfiltration, or remote code execution. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-44170CVSS 9.8MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB on WIndows with installed CONNECT engine and enabled REST support interpolated table HTTP attribute into the curl command line without proper sanitizing. This allows the user to execute shell commands on the server. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-86047. Free for 1 server.

Get started free