medium CVSS 5.4 EPSS 0.45%

CVE-2026-85985·MariaDB vulnerability

MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the CONNECT engine plugin file-access UDFs json_file(), bson_file(), jfile_make(), bfile_make(), and jbin_file() are affected because each does not enforce FILE privilege or the secure_file_priv setting. A low-privileged attacker can trigger the issue by calling a CONNECT file-access UDF with a filesystem path, then invoke a CONNECT file-access UDF to access a filesystem path and read or write files that the database account is not authorized to access, subject to operating-system permissions. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

Severity
medium
Software
MariaDB
Fixed in
12.3.3
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.45% — higher than 39% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

From: 12.3.1

Until: 12.3.3

Fixed in: 12.3.3

How to fix this CVE

Update MariaDB to version 11.8.9 or later to patch a privilege bypass vulnerability in the CONNECT engine's file-access functions. These UDFs (json_file, bson_file, jfile_make, bfile_make, jbin_file) were not properly validating FILE privileges or secure_file_priv settings, allowing unauthorized file read/write operations. Immediately patch all affected MariaDB instances to prevent privilege escalation attacks.

sudo dnf update mariadb-server

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check installed MariaDB version with: mysql --version or mariadb --version
  2. Step 2: Query the database for CONNECT engine status: SELECT * FROM INFORMATION_SCHEMA.ENGINES WHERE ENGINE='CONNECT';
  3. Step 3: Search MariaDB error logs for calls to vulnerable UDF functions: grep -E 'json_file|bson_file|jfile_make|bfile_make|jbin_file' /var/log/mysql/error.log
  4. Step 4: Verify patched version is installed by confirming MariaDB version is 11.8.9 or later: SELECT VERSION();

FAQ

What is CVE-2026-85985?

A privilege bypass vulnerability in MariaDB's CONNECT engine plugin where file-access UDF functions fail to validate FILE privileges or respect secure_file_priv restrictions, enabling low-privileged users to read or write arbitrary files accessible to the database process.

Is CVE-2026-85985 being actively exploited?

No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are known to be available.

What versions of MariaDB are affected by CVE-2026-85985?

Vulnerable versions include 10.6.1 through 10.6.27, 10.11.0 through 10.11.18, 11.4.0 through 11.4.12, 11.8.0 through 11.8.8, 12.3.0 through 12.3.2, and all versions before 13.0.2.

How do I check if my server is vulnerable to CVE-2026-85985?

Run: mariadb --version and compare output to affected ranges. If your version is lower than the patched versions (10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, or 13.0.2), you are vulnerable.

Does Defensia detect CVE-2026-85985?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MariaDB is installed on a monitored server, CVE-2026-85985 will appear in your dashboard with remediation steps.

Related MariaDB CVEs

CVE-2026-49261CVSS 10MariaDB server is a community developed fork of MySQL server. Versions 10.6.1 through 10.6.26, 10.11.1 through 10.11.17, 11.4.1 through 11.4.11, 11.8.1 through 11.8.7, and 12.3.1 with `wsrep_notify_cmd` enabled would execute shell commands embedded in the name of the joiner node. This is fixed in 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2. As a workaround, anyone who cannot upgrade now should disable `wsrep_notify_cmd`.
CVE-2026-85748CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 12.3.1 until 12.3.3 and 13.0.2, SYS_REFCURSOR handling is affected because cursor-array reallocation can leave stale references in routine contexts. A low-privileged attacker can open a large number of SYS_REFCURSORs and then fetch one to trigger a use-after-free that can enable remote code execution when combined with another vulnerability. This issue is fixed in versions 12.3.3 and 13.0.2.
CVE-2026-85746CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, ST_AsText can write beyond an allocated output buffer when converting deeply nested GeometryCollections because recursive WKT serialization does not account for bytes consumed or reserve sufficient space. A low-privileged remote attacker can submit a specially crafted GIS object to corrupt memory and potentially achieve code execution when combined with another vulnerability. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-92262CVSS 9.9MariaDB server is a community developed fork of MySQL server. From 10.6.1 until 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2, the #mysql50# bypass prefix is affected because it allows the #mysql50# prefix to bypass normal table-name filesystem encoding. An attacker can trigger the issue with a table name using the #mysql50# prefix, then use a #mysql50# table name to access files under their legacy unencoded name and cause crashes, data corruption, data exfiltration, or remote code execution. This issue is fixed in versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.
CVE-2026-44170CVSS 9.8MariaDB server is a community developed fork of MySQL server. From versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, MariaDB on WIndows with installed CONNECT engine and enabled REST support interpolated table HTTP attribute into the curl command line without proper sanitizing. This allows the user to execute shell commands on the server. This issue has been patched in versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-85985. Free for 1 server.

Get started free