CVE-2026-66373·Redis vulnerability
Redis before 8.8.0, in the unusual case where an authenticated attacker can execute RESTORE, allows remote code execution via a RESTORE payload where the same NACK (pending entry) is referenced by more than one consumer, because deleting both consumers via XGROUP DELCONSUMER leads to a double free. NOTE: this issue exists because of an incomplete fix for CVE-2026-25243.
- Severity
- high
- Software
- Redis
- Fixed in
- 5:7.0.15-1~deb12u9
- Published
Affected versions
Until: 5:7.0.15-1~deb12u9
Fixed in: 5:7.0.15-1~deb12u9
How to fix this CVE
Upgrade Redis to version 7.0.15-1~deb12u9 or later to remediate this memory corruption vulnerability. The vulnerability requires authenticated access and specific conditions involving stream consumer groups, but poses a critical remote code execution risk. Apply the patch immediately across all Redis instances in your infrastructure, particularly those accepting remote connections.
sudo dnf update redisDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed Redis version with `redis-cli --version` or `redis-server --version` and compare against 7.0.15-1~deb12u9
- Step 2: Verify Redis ACL configuration by running `redis-cli ACL LIST` to identify users with RESTORE command permissions
- Step 3: Query Redis command history with `redis-cli COMMAND INFO RESTORE XGROUP DELCONSUMER` to check if these commands are accessible to non-admin accounts
- Step 4: After patching, confirm the update with `redis-cli INFO server` and verify the version string reflects the fixed version
FAQ
What is CVE-2026-66373?
This vulnerability is a double-free memory corruption bug in Redis that occurs when a stream consumer group references the same pending entry (NACK) through multiple consumers, and both are deleted via XGROUP DELCONSUMER. An authenticated attacker can exploit this through a malformed RESTORE payload to achieve remote code execution.
Is CVE-2026-66373 being actively exploited?
No, according to CISA's Known Exploited Vulnerabilities catalog, CVE-2026-66373 is not currently being exploited in the wild, and no public exploits are available.
What versions of Redis are affected by CVE-2026-66373?
All versions prior to 7.0.15-1~deb12u9 are affected. This includes Redis 7.0.x and earlier branches. The vulnerability was introduced as an incomplete fix for a prior issue (CVE-2026-25243).
How do I check if my server is vulnerable to CVE-2026-66373?
Run `redis-cli --version` or `redis-server --version` and compare the version string to 7.0.15-1~deb12u9. If your version is older, the instance is vulnerable.
Does Defensia detect CVE-2026-66373?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Redis is installed on a monitored server, CVE-2026-66373 will appear in your dashboard with remediation steps.
Related Redis CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-66373. Free for 1 server.
Get started free