high CVSS 8.1 EPSS 2.8%

CVE-2026-23631·Redis vulnerability

Redis is an in-memory data structure store. In all versions of redis-server with Lua scripting, an authenticated attacker can exploit the master-replica synchronization mechanism to trigger a use-after-free on replicas where replica-read-only is disabled or can be disabled, which may lead to remote code execution. A workaround is to prevent users from executing Lua scripts or avoid using replicas where replica-read-only is disabled. This is patched in version 8.6.3.

Severity
high
Software
Redis
Fixed in
8.6.3
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 2.8% — higher than 86% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 8.6.3

Fixed in: 8.6.3

How to fix this CVE

Upgrade Redis to version 8.6.3 or later to patch a critical use-after-free vulnerability in the Lua scripting engine that can be triggered during master-replica synchronization. Organizations should prioritize this update immediately, particularly if they run replicas with replica-read-only disabled or have Lua script execution enabled. Until patching is complete, restrict Lua script execution permissions and ensure replica-read-only mode is enforced across all replica instances.

sudo dnf update redis

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed Redis version: redis-cli INFO server | grep redis_version
  2. Verify replica-read-only setting: redis-cli CONFIG GET replica-read-only (should return 'yes' for safety)
  3. Review Redis command logs for EVAL or EVALSHA commands: redis-cli SLOWLOG GET 100 | grep -i eval
  4. Confirm patch application: redis-cli INFO server should show version 8.6.3 or higher

FAQ

What is CVE-2026-23631?

This is a use-after-free vulnerability in Redis Lua scripting that occurs during master-replica data synchronization when replica-read-only mode is disabled. An authenticated attacker can exploit this flaw to achieve remote code execution on vulnerable replica instances.

Is CVE-2026-23631 being actively exploited?

No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities catalog and no public exploits are available. However, given its high CVSS score of 8.1 and RCE potential, prompt patching is still critical.

What versions of Redis are affected by CVE-2026-23631?

All versions of Redis prior to 8.6.3 are vulnerable. The exact lower bound is not specified, so assume all legacy and current versions are in scope unless explicitly tested.

How do I check if my server is vulnerable to CVE-2026-23631?

Run `redis-cli INFO server | grep redis_version` to check your version. If it reports anything below 8.6.3, your instance is vulnerable. Additionally, run `redis-cli CONFIG GET replica-read-only` on replicas—if it returns 'no', the replica is exposed to exploitation.

Does Defensia detect CVE-2026-23631?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Redis is installed on a monitored server, CVE-2026-23631 will appear in your dashboard with remediation steps.

Related Redis CVEs

CVE-2022-0543CVSS 10It was discovered, that redis, a persistent key-value database, due to a packaging issue, is prone to a (Debian-specific) Lua sandbox escape, which could result in remote code execution.
CVE-2026-23479CVSS 8.8Redis is an in-memory data structure store. In redis-server from 7.2.0 until 8.6.3, the unblock client flow does not handle an error return from `processCommandAndResetClient` when re-executing a blocked command. If a blocked client is evicted during this flow, an authenticated attacker can trigger a use-after-free that may lead to remote code execution. This has been patched in version 8.6.3.
CVE-2026-25243CVSS 8.8Redis is an in-memory data structure store. In versions of redis-server up to 8.6.3, the RESTORE command does not properly validate serialized values. An authenticated attacker with permission to execute RESTORE can supply a crafted serialized payload that triggers invalid memory access and may lead to remote code execution. A workaround is to restrict access to the RESTORE command with ACL rules. This is patched in version 8.6.3.
CVE-2018-12326CVSS 8.5Buffer overflow in redis-cli of Redis before 4.0.10 and 5.x before 5.0 RC3 allows an attacker to achieve code execution and escalate to higher privileges via a crafted command line. NOTE: It is unclear whether there are any common situations in which redis-cli is used with, for example, a -h (aka hostname) argument from an untrusted source.
CVE-2026-66373CVSS 8.5Redis before 8.8.0, in the unusual case where an authenticated attacker can execute RESTORE, allows remote code execution via a RESTORE payload where the same NACK (pending entry) is referenced by more than one consumer, because deleting both consumers via XGROUP DELCONSUMER leads to a double free. NOTE: this issue exists because of an incomplete fix for CVE-2026-25243.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-23631. Free for 1 server.

Get started free