high CVSS 8.8 EPSS 3.7%

CVE-2026-25243·Redis vulnerability

Redis is an in-memory data structure store. In versions of redis-server up to 8.6.3, the RESTORE command does not properly validate serialized values. An authenticated attacker with permission to execute RESTORE can supply a crafted serialized payload that triggers invalid memory access and may lead to remote code execution. A workaround is to restrict access to the RESTORE command with ACL rules. This is patched in version 8.6.3.

Severity
high
Software
Redis
Fixed in
8.6.3
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 3.7% — higher than 89% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 8.6.3

Fixed in: 8.6.3

How to fix this CVE

Upgrade Redis to version 8.6.3 or later to patch a critical vulnerability in the RESTORE command that could allow authenticated attackers to trigger memory corruption and potentially execute arbitrary code. Organizations unable to upgrade immediately should restrict RESTORE command access using Redis ACL rules to limit exposure to trusted administrators only.

sudo dnf update redis

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check the installed Redis version by running `redis-cli INFO server | grep redis_version` or `redis-server --version`
  2. Step 2: Verify if the RESTORE command is accessible to non-admin users by running `redis-cli ACL LIST` and checking for RESTORE permissions in user ACLs
  3. Step 3: Search Redis logs for RESTORE command usage patterns with `grep -i RESTORE /var/log/redis/*.log` or check Redis slow log via `redis-cli SLOWLOG GET 100`
  4. Step 4: After patching, confirm the update with `redis-cli INFO server | grep redis_version` and verify it shows 8.6.3 or later

FAQ

What is CVE-2026-25243?

This vulnerability exists in Redis's RESTORE command, which deserializes data from binary payloads. Attackers who can authenticate to Redis can craft malicious serialized data that causes invalid memory access, potentially leading to code execution with Redis process privileges.

Is CVE-2026-25243 being actively exploited?

No, this vulnerability is not currently listed in CISA's Known Exploited Vulnerabilities catalog and no public exploits are available, though it should still be patched promptly due to its high severity and authentication requirement.

What versions of Redis are affected by CVE-2026-25243?

All versions of Redis up to and including 8.6.2 are vulnerable. Version 8.6.3 and later contain the fix.

How do I check if my server is vulnerable to CVE-2026-25243?

Run `redis-cli INFO server` and examine the `redis_version` field. If it is 8.6.2 or earlier, your server is vulnerable. Additionally, check if the RESTORE command is permitted via `redis-cli ACL LIST` to understand your exposure.

Does Defensia detect CVE-2026-25243?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Redis is installed on a monitored server, CVE-2026-25243 will appear in your dashboard with remediation steps.

Related Redis CVEs

CVE-2022-0543CVSS 10It was discovered, that redis, a persistent key-value database, due to a packaging issue, is prone to a (Debian-specific) Lua sandbox escape, which could result in remote code execution.
CVE-2026-23479CVSS 8.8Redis is an in-memory data structure store. In redis-server from 7.2.0 until 8.6.3, the unblock client flow does not handle an error return from `processCommandAndResetClient` when re-executing a blocked command. If a blocked client is evicted during this flow, an authenticated attacker can trigger a use-after-free that may lead to remote code execution. This has been patched in version 8.6.3.
CVE-2018-12326CVSS 8.5Buffer overflow in redis-cli of Redis before 4.0.10 and 5.x before 5.0 RC3 allows an attacker to achieve code execution and escalate to higher privileges via a crafted command line. NOTE: It is unclear whether there are any common situations in which redis-cli is used with, for example, a -h (aka hostname) argument from an untrusted source.
CVE-2026-66373CVSS 8.5Redis before 8.8.0, in the unusual case where an authenticated attacker can execute RESTORE, allows remote code execution via a RESTORE payload where the same NACK (pending entry) is referenced by more than one consumer, because deleting both consumers via XGROUP DELCONSUMER leads to a double free. NOTE: this issue exists because of an incomplete fix for CVE-2026-25243.
CVE-2026-23631CVSS 8.1Redis is an in-memory data structure store. In all versions of redis-server with Lua scripting, an authenticated attacker can exploit the master-replica synchronization mechanism to trigger a use-after-free on replicas where replica-read-only is disabled or can be disabled, which may lead to remote code execution. A workaround is to prevent users from executing Lua scripts or avoid using replicas where replica-read-only is disabled. This is patched in version 8.6.3.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-25243. Free for 1 server.

Get started free